Every CVE Search/ Get API key

CVE-2021-3693

Cross-site Scripting (XSS) - DOM in ledgersmb/ledgersmb

8.8 HighFix available

LedgerSMB does not check the origin of HTML fragments merged into the browser's DOM. By sending a specially crafted URL to an authenticated user, this flaw can be abused for remote code execution and information disclosure.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.17%Up 1.7 points since Aug 24, 2021
90%50%10%1%

What each source reports

CVE List Score used 8.8

Cross-site Scripting (XSS) - DOM in ledgersmb/ledgersmb

LedgerSMB does not check the origin of HTML fragments merged into the browser's DOM. By sending a specially crafted URL to an authenticated user, this flaw can be abused for remote code execution and information disclosure.

Record
CVE-2021-3693
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2021-26978 8.8

LedgerSMB does not check the origin of HTML fragments merged into the browser's DOM. By sending a specially crafted URL to an authenticated user, this flaw can be abused for remote code execution and information disclosure.

Record
EUVD-2021-26978
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-x27f-prq2-qwh6 No score

LedgerSMB does not check the origin of HTML fragments merged into the browser's DOM. By sending a...

LedgerSMB does not check the origin of HTML fragments merged into the browser's DOM. By sending a specially crafted URL to an authenticated user, this flaw can be abused for remote code execution and information disclosure.

Record
GHSA-x27f-prq2-qwh6
Weakness
CWE-79
Updated
2026-11-02
NVD 8.8

LedgerSMB does not check the origin of HTML fragments merged into the browser's DOM. By sending a specially crafted URL to an authenticated user, this flaw can be abused for remote code execution and information disclosure.

Record
CVE-2021-3693
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.1
9.6 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-79
Updated
2026-11-02
OSV 9.6

LedgerSMB does not check the origin of HTML fragments merged into the browser's DOM. By sending a specially crafted URL to an authenticated user, this flaw can be abused for remote code execution and information disclosure.

Record
CVE-2021-3693
CVSS 3.1
9.6 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-3693 9.6

LedgerSMB does not check the origin of HTML fragments merged into the browser's DOM. By sending a specially crafted URL to an authenticated user, this flaw can be abused for remote code execution and information disclosure.

Record
DEBIAN-CVE-2021-3693
CVSS 3.1
9.6 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-3693 8.8

LedgerSMB does not check the origin of HTML fragments merged into the browser's DOM. By sending a specially crafted URL to an authenticated user, this flaw can be abused for remote code execution and information disclosure.

Record
UBUNTU-CVE-2021-3693
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.1
9.6 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-5097-1 No score

ledgersmb vulnerabilities

It was discovered that LedgerSMB incorrectly handled certain inputs. An attacker could use this to leak sensitive information, cause a DoS, or execute arbitrary code. (CVE-2021-3693, CVE-2021-3694, CVE-2021-3731)

Record
USN-5097-1
Updated
2026-11-02
OSVUSN-7647-1 No score

ledgersmb vulnerabilities

It was discovered that LedgerSMB did not check the origin of HTML fragments. An attacker could possibly use this issue to send a maliciously crafted URL to the server and obtain sensitive information, or execute arbitrary code. This issue only affected Ubuntu 22.04 LTS, Ubuntu 24.04 LTS, and Ubuntu 25.04. (CVE-2021-3693)

It was discovered that LedgerSMB did not properly encode HTML error messages. An attacker could possibly use this issue to send a maliciously crafted URL to the server and obtain sensitive information, or execute arbitrary code. This issue only affected Ubuntu 18.04 LTS. (CVE-2021-3694)

It was discovered that LedgerSMB did not guard against discrete link redirections. An attacker could possibly use this issue to obtain sensitive information. This issue only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-2021-3731)

It was discovered that LedgerSMB did not properly set the 'Secure' attribute during HTTPS sessions. If a user were tricked into using an unencrypted connection, an attacker could possibly use this issue to obtain sensitive information. This issue only affected Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, Ubuntu 24.04 LTS, and Ubuntu 25.04. (CVE-2021-3882)

It was discovered that LedgerSMB could create admin accounts via a URL. If an admin were tricked into clicking a maliciously crafted URL, an attacker could possibly use this issue to achieve privilege escalation. This issue only affected Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, Ubuntu 24.04 LTS, and Ubuntu 25.04. (CVE-2024-23831)

Record
USN-7647-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ledgersmb
Debian:12
before 1.6.9+ds-2.1
1.6.9+ds-2.1
ledgersmb
Debian:10
From an advisory covering 3 CVEs
before 1.6.9+ds-1+deb10u2, plus listed versions
1.6.9+ds-11.6.9+ds-1+deb10u1
1.6.9+ds-1+deb10u2
ledgersmb
Debian:11
From an advisory covering 3 CVEs
before 1.6.9+ds-2+deb11u2, plus listed versions
1.6.9+ds-21.6.9+ds-2+deb11u1
1.6.9+ds-2+deb11u2
ledgersmb
Ubuntu:Pro:16.04:LTS
before 1.3.46-1ubuntu0.1~esm1, plus listed versions
1.3.46-1
1.3.46-1ubuntu0.1~esm1
ledgersmb
Ubuntu:Pro:18.04:LTS
before 1.4.42+ds-1ubuntu0.1~esm1, plus listed versions
1.4.41+ds-11.4.42+ds-1
1.4.42+ds-1ubuntu0.1~esm1
ledgersmb
Ubuntu:20.04:LTS
before 1.6.9+ds-1ubuntu0.1, plus listed versions
1.6.9+ds-1
1.6.9+ds-1ubuntu0.1
ledgersmb
Ubuntu:22.04:LTS
before 1.6.33+ds-1ubuntu0.1, plus listed versions
1.6.9+ds-2.11.6.33+ds-1
1.6.33+ds-1ubuntu0.1
ledgersmb
Ubuntu:24.04:LTS
before 1.6.33+ds-2.1ubuntu0.1, plus listed versions
1.6.33+ds-2.1
1.6.33+ds-2.1ubuntu0.1
ledgersmb
Ubuntu:20.04:LTS
From an advisory covering 3 CVEs
before 1.6.9+ds-1ubuntu0.1, plus listed versions
1.6.9+ds-1
1.6.9+ds-1ubuntu0.1
ledgersmb
Ubuntu:Pro:16.04:LTS
From an advisory covering 5 CVEs
before 1.3.46-1ubuntu0.1~esm1, plus listed versions
1.3.46-1
1.3.46-1ubuntu0.1~esm1
Show 4 moreShow less
Affected packages
PackageAffectedFixed
ledgersmb
Ubuntu:Pro:18.04:LTS
From an advisory covering 5 CVEs
before 1.4.42+ds-1ubuntu0.1~esm1, plus listed versions
1.4.41+ds-11.4.42+ds-1
1.4.42+ds-1ubuntu0.1~esm1
ledgersmb
Ubuntu:Pro:20.04:LTS
From an advisory covering 5 CVEs
before 1.6.9+ds-1ubuntu0.1+esm1, plus listed versions
1.6.9+ds-11.6.9+ds-1ubuntu0.1
1.6.9+ds-1ubuntu0.1+esm1
ledgersmb
Ubuntu:22.04:LTS
From an advisory covering 5 CVEs
before 1.6.33+ds-1ubuntu0.1, plus listed versions
1.6.9+ds-2.11.6.33+ds-1
1.6.33+ds-1ubuntu0.1
ledgersmb
Ubuntu:24.04:LTS
From an advisory covering 5 CVEs
before 1.6.33+ds-2.1ubuntu0.1, plus listed versions
1.6.33+ds-2.1
1.6.33+ds-2.1ubuntu0.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-3693 is a high vulnerability (CVSS 8.8) in Ledgersmb, published August 23, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.17%, the 88th percentile. Fixed in ledgersmb 1.6.9+ds-2.1.

References

Show 8 moreShow less
MoveEnter Open