CVE-2004-0547
Buffer overflow in the ODBC driver for PostgreSQL before 7.2.1 allows remote attackers to cause a...
Buffer overflow in the ODBC driver for PostgreSQL before 7.2.1 allows remote attackers to cause a denial of service (crash).
Exploit likelihood
What each source reports
NVD Score used
5.0
Buffer overflow in the ODBC driver for PostgreSQL before 7.2.1 allows remote attackers to cause a denial of service (crash).
- Record
CVE-2004-0547- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Updated
- 2026-11-02
CVE List No score
Buffer overflow in the ODBC driver for PostgreSQL before 7.2.1 allows remote attackers to cause a denial of service (crash).
- Record
CVE-2004-0547- Updated
- 2026-11-02
EUVDEUVD-2004-0546 No score
Buffer overflow in the ODBC driver for PostgreSQL before 7.2.1 allows remote attackers to cause a denial of service (crash).
- Record
EUVD-2004-0546- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-83x8-fwcx-3pmf No score
Buffer overflow in the ODBC driver for PostgreSQL before 7.2.1 allows remote attackers to cause a...
Buffer overflow in the ODBC driver for PostgreSQL before 7.2.1 allows remote attackers to cause a denial of service (crash).
- Record
GHSA-83x8-fwcx-3pmf- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
postgresqlDebian:3.0 |
before 7.2.1-2woody5 | 7.2.1-2woody5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2004-0547 is a medium vulnerability (CVSS 5.0) in Postgresql, published June 7, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.67%, the 85th percentile. Fixed in postgresql 7.2.1-2woody5.