Every CVE Search/ Get API key

CVE-2004-0492

Heap-based buffer overflow in proxy_util.c for mod_proxy in Apache 1.3.25 to 1.3.31 allows remote...

10.0 HighFix available

Heap-based buffer overflow in proxy_util.c for mod_proxy in Apache 1.3.25 to 1.3.31 allows remote attackers to cause a denial of service (process crash) and possibly execute arbitrary code via a negative Content-Length HTTP header field, which causes a large amount of data to be copied.

Exploit likelihood

33.6%Up 9.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

Heap-based buffer overflow in proxy_util.c for mod_proxy in Apache 1.3.25 to 1.3.31 allows remote attackers to cause a denial of service (process crash) and possibly execute arbitrary code via a negative Content-Length HTTP header field, which causes a large amount of data to be copied.

Record
CVE-2004-0492
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in proxy_util.c for mod_proxy in Apache 1.3.25 to 1.3.31 allows remote attackers to cause a denial of service (process crash) and possibly execute arbitrary code via a negative Content-Length HTTP header field, which causes a large amount of data to be copied.

Record
CVE-2004-0492
Updated
2026-11-02
EUVDEUVD-2004-0491 No score

Heap-based buffer overflow in proxy_util.c for mod_proxy in Apache 1.3.25 to 1.3.31 allows remote attackers to cause a denial of service (process crash) and possibly execute arbitrary code via a negative Content-Length HTTP header field, which causes a large amount of data to be copied.

Record
EUVD-2004-0491
Updated
2026-11-03
GitHub AdvisoriesGHSA-w59m-3c5g-3v9c No score

Heap-based buffer overflow in proxy_util.c for mod_proxy in Apache 1.3.25 to 1.3.31 allows remote...

Heap-based buffer overflow in proxy_util.c for mod_proxy in Apache 1.3.25 to 1.3.31 allows remote attackers to cause a denial of service (process crash) and possibly execute arbitrary code via a negative Content-Length HTTP header field, which causes a large amount of data to be copied.

Record
GHSA-w59m-3c5g-3v9c
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apache
Debian:3.0
before 1.3.26-0woody5
1.3.26-0woody5

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0492 is a high vulnerability (CVSS 10.0) in Apache Http Server, published June 23, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 33.6%, the 98th percentile. Fixed in apache 1.3.26-0woody5.

References

Show 26 moreShow less
MoveEnter Open