Every CVE Search/ Get API key

CVE-2022-3328

snapd Race Condition vulnerability

7.8 HighPublic exploitFix available

Race condition in snap-confine's must_mkdir_and_open_with_perms()

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.38%Up 0.3 points since Jan 10, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.8

Race condition in snap-confine's must_mkdir_and_open_with_perms()

Record
CVE-2022-3328
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-362
Updated
2026-11-02
EUVDEUVD-2024-0335 7.8

Race condition in snap-confine's must_mkdir_and_open_with_perms()

Record
EUVD-2024-0335
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-cjqf-877p-7m3f 9.0

snapd Race Condition vulnerability

Race condition in snap-confine's must_mkdir_and_open_with_perms()

Record
GHSA-cjqf-877p-7m3f
CVSS 4.0
9.0 CriticalCVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-362
Updated
2026-11-02
NVD 7.8

Race condition in snap-confine's must_mkdir_and_open_with_perms()

Record
CVE-2022-3328
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-362
Updated
2026-11-02
OSV 7.8

Race condition in snap-confine's must_mkdir_and_open_with_perms()

Record
CVE-2022-3328
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2022-3328 7.0

Race condition in snap-confine's must_mkdir_and_open_with_perms()

Record
DEBIAN-CVE-2022-3328
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
Show 4 moreShow less
OSVGHSA-cjqf-877p-7m3f 9.0

snapd Race Condition vulnerability

Race condition in snap-confine's must_mkdir_and_open_with_perms()

Record
GHSA-cjqf-877p-7m3f
CVSS 4.0
9.0 CriticalCVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-362
Updated
2026-11-02
OSVUBUNTU-CVE-2022-3328 7.8

Race condition in snap-confine's must_mkdir_and_open_with_perms()

Record
UBUNTU-CVE-2022-3328
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGO-2024-2468 No score

snapd Race Condition vulnerability in github.com/snapcore/snapd

snapd Race Condition vulnerability in github.com/snapcore/snapd.

NOTE: The source advisory for this report contains additional versions that could not be automatically mapped to standard Go module versions.

(If this is causing false-positive reports from vulnerability scanners, please suggest an edit to the report.)

The additional affected modules and versions are: github.com/snapcore/snapd before v2.57.6.

Record
GO-2024-2468
Updated
2026-11-02
OSVUSN-5753-1 No score

snapd vulnerability

The Qualys Research Team discovered that a race condition existed in the snapd snap-confine binary when preparing the private /tmp mount for a snap. A local attacker could possibly use this issue to escalate privileges and execute arbitrary code.

Record
USN-5753-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/snapcore/snapd
Go
before 2.57.6
2.57.6
snapd
Debian:12
before 2.57.6-1
2.57.6-1
snapd
Debian:13
before 2.57.6-1
2.57.6-1
snapd
Debian:14
before 2.57.6-1
2.57.6-1
snapd
Debian:10
before 2.37.4-1+deb10u2, plus listed versions
2.37.4-12.37.4-1+deb10u1
2.37.4-1+deb10u2
snapd
Debian:11
before 2.49-1+deb11u2, plus listed versions
2.49-12.49-1+deb11u1
2.49-1+deb11u2
github.com/snapcore/snapd
Go
All versions None known
snapd
Ubuntu:Pro:16.04:LTS
before 2.54.3+16.04.0ubuntu0.1~esm5, plus listed versions
1.91.9.1.11.9.22.02.0.1
Show 45 moreShow less
2.0.22.0.32.0.52.0.82.0.92.0.102.11+0.16.042.12+0.16.042.132.14.2~16.042.15.2ubuntu12.16ubuntu32.17.1ubuntu12.20.1ubuntu12.212.22.22.22.32.22.62.23.12.24.12.252.26.102.27.52.28.52.29.4.22.32.3.22.32.92.33.1ubuntu22.34.22.34.2ubuntu0.12.37.42.37.4ubuntu0.12.382.39.22.39.2ubuntu0.22.402.42.12.45.12.45.1ubuntu0.22.46.12.47.12.482.48.32.54.3+16.04~esm22.54.3+16.04.0ubuntu0.1~esm3
2.54.3+16.04.0ubuntu0.1~esm5
snapd
Ubuntu:18.04:LTS
before 2.57.5+18.04ubuntu0.1, plus listed versions
2.28.5+17.102.29.4.1+18.042.29.4.2+18.042.31.1+18.042.32+18.04~pre5
Show 31 moreShow less
2.32+18.04~pre62.32+18.042.32.3.2+18.042.32.5+18.042.32.8+18.042.32.9+18.042.33.1+18.04ubuntu22.34.2+18.042.34.2+18.04.12.37.1+18.042.37.1.1+18.042.37.4+18.042.37.4+18.04.12.38+18.042.39.2+18.042.40+18.042.42.1+18.042.45.1+18.042.45.1+18.04.22.46.1+18.042.47.1+18.042.48+18.042.48.3+18.042.49.2+18.042.51.1+18.042.54.2+18.04ubuntu12.54.3+18.042.54.3+18.04.2ubuntu0.12.54.3+18.04.2ubuntu0.22.55.5+18.042.57.5+18.04
2.57.5+18.04ubuntu0.1
snapd
Ubuntu:20.04:LTS
before 2.57.5+20.04ubuntu0.1, plus listed versions
2.41+19.10.12.42.1+20.042.43.3+git1.8109f82.44~pre1+20.042.44+20.04
Show 18 moreShow less
2.44.2+20.042.44.3+20.042.45.1+20.042.45.1+20.04.22.46.1+20.042.47.1+20.042.48+20.042.48.3+20.042.49.2+20.042.51.1+20.04ubuntu22.54.2+20.04ubuntu22.54.3+20.042.54.3+20.04.12.54.3+20.04.1ubuntu0.12.54.3+20.04.1ubuntu0.22.54.3+20.04.1ubuntu0.32.55.5+20.042.57.5+20.04
2.57.5+20.04ubuntu0.1
snapd
Ubuntu:22.04:LTS
before 2.57.5+22.04ubuntu0.1, plus listed versions
2.53+21.10ubuntu12.54.2+22.04ubuntu12.54.2+22.04ubuntu22.54.2+22.04ubuntu32.54.3+git19.g868fc21+22.04
Show 9 moreShow less
2.54.3+git26.g360067e+22.042.55.2+22.042.55.2+22.04.12.55.3+22.042.55.3+22.04ubuntu12.55.5+22.042.56.2+22.04ubuntu12.57.4+22.042.57.5+22.04
2.57.5+22.04ubuntu0.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubMr-xn/CVE-2022-33282022-12-01

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-3328 is a high vulnerability (CVSS 7.8) in Canonical Snapd, published November 30, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.38%, the 32nd percentile. Fixed in github.com/snapcore/snapd 2.57.6.

References

Show 6 moreShow less
This page doesn't list everything

Left out here: 1 version. The JSON record has them.

MoveEnter Open