Every CVE Search/ Get API key

CVE-2004-0802

Buffer overflow in the BMP loader in imlib2 before 1.1.2 allows remote attackers to execute...

5.1 MediumFix available

Buffer overflow in the BMP loader in imlib2 before 1.1.2 allows remote attackers to execute arbitrary code via a specially-crafted BMP image, a different vulnerability than CVE-2004-0817.

Exploit likelihood

3.43%Down 4.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.1

Buffer overflow in the BMP loader in imlib2 before 1.1.2 allows remote attackers to execute arbitrary code via a specially-crafted BMP image, a different vulnerability than CVE-2004-0817.

Record
CVE-2004-0802
CVSS 2.0
5.1 MediumAV:N/AC:H/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Buffer overflow in the BMP loader in imlib2 before 1.1.2 allows remote attackers to execute arbitrary code via a specially-crafted BMP image, a different vulnerability than CVE-2004-0817.

Record
CVE-2004-0802
Updated
2026-11-02
EUVDEUVD-2004-0800 No score

Buffer overflow in the BMP loader in imlib2 before 1.1.2 allows remote attackers to execute arbitrary code via a specially-crafted BMP image, a different vulnerability than CVE-2004-0817.

Record
EUVD-2004-0800
Updated
2026-11-03
GitHub AdvisoriesGHSA-pv68-cmw6-5544 No score

Buffer overflow in the BMP loader in imlib2 before 1.1.2 allows remote attackers to execute...

Buffer overflow in the BMP loader in imlib2 before 1.1.2 allows remote attackers to execute arbitrary code via a specially-crafted BMP image, a different vulnerability than CVE-2004-0817.

Record
GHSA-pv68-cmw6-5544
Updated
2026-11-02
OSV No score

Buffer overflow in the BMP loader in imlib2 before 1.1.2 allows remote attackers to execute arbitrary code via a specially-crafted BMP image, a different vulnerability than CVE-2004-0817.

Record
CVE-2004-0802
Updated
2026-11-02
OSVDEBIAN-CVE-2004-0802 No score

Buffer overflow in the BMP loader in imlib2 before 1.1.2 allows remote attackers to execute arbitrary code via a specially-crafted BMP image, a different vulnerability than CVE-2004-0817.

Record
DEBIAN-CVE-2004-0802
Updated
2026-11-02

Affected products

Show 4 moreShow less

Affected packages

Affected packages
PackageAffectedFixed
imlib2
Debian:12
before 1.1.0-12.4
1.1.0-12.4
imlib2
Debian:13
before 1.1.0-12.4
1.1.0-12.4
imlib2
Debian:14
before 1.1.0-12.4
1.1.0-12.4
imlib2
Debian:3.0
before 1.0.5-2woody1
1.0.5-2woody1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0802 is a medium vulnerability (CVSS 5.1) in Enlightenment Imlib, published September 22, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.43%, the 88th percentile. Fixed in imlib2 1.1.0-12.4.

References

Show 5 moreShow less
MoveEnter Open