Every CVE Search/ Get API key

CVE-2024-4058

Type confusion in ANGLE in Google Chrome prior to 124.0.6367.78 allowed a remote attacker to...

8.8 HighFix available

Type confusion in ANGLE in Google Chrome prior to 124.0.6367.78 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Critical)

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

8.83%Up 8.8 points since May 2, 2024
90%50%10%1%

What each source reports

NVD Score used 8.8

Type confusion in ANGLE in Google Chrome prior to 124.0.6367.78 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Critical)

Record
CVE-2024-4058
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.1
9.0 CriticalCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-843
Updated
2026-11-02
CVE List 9.0

Type confusion in ANGLE in Google Chrome prior to 124.0.6367.78 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Critical)

Record
CVE-2024-4058
CVSS 3.1
9.0 CriticalCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-843
Updated
2026-11-02
EUVDEUVD-2024-32623 9.0

Type confusion in ANGLE in Google Chrome prior to 124.0.6367.78 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Critical)

Record
EUVD-2024-32623
CVSS 3.1
9.0 CriticalCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-23rw-79p3-xgcm 8.8

Type confusion in ANGLE in Google Chrome prior to 124.0.6367.78 allowed a remote attacker to...

Type confusion in ANGLE in Google Chrome prior to 124.0.6367.78 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Critical)

Record
GHSA-23rw-79p3-xgcm
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-843
Updated
2026-11-02
OSVALPINE-CVE-2024-4058 8.8

Type confusion in ANGLE in Google Chrome prior to 124.0.6367.78 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Critical)

Record
ALPINE-CVE-2024-4058
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 8.8

Type confusion in ANGLE in Google Chrome prior to 124.0.6367.78 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Critical)

Record
CVE-2024-4058
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2024-4058 8.8

Type confusion in ANGLE in Google Chrome prior to 124.0.6367.78 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: Critical)

Record
DEBIAN-CVE-2024-4058
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:13924-1 No score

nodejs-electron-29.3.2~20240430g19f0abd6-1.1 on GA media

These are all security issues fixed in the nodejs-electron-29.3.2~20240430g19f0abd6-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:13924-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:13953-1 No score

chromedriver-124.0.6367.201-1.1 on GA media

These are all security issues fixed in the chromedriver-124.0.6367.201-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:13953-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:14548-1 No score

libQt5Pdf5-5.15.18-1.1 on GA media

These are all security issues fixed in the libQt5Pdf5-5.15.18-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:14548-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
qt5-qtwebengine
Alpine:v3.20
before 5.15.16-r9
5.15.16-r9
qt5-qtwebengine
Alpine:v3.21
before 5.15.17-r0
5.15.17-r0
qt5-qtwebengine
Alpine:v3.22
before 5.15.17-r0
5.15.17-r0
qt5-qtwebengine
Alpine:v3.23
before 5.15.17-r0
5.15.17-r0
qt6-qtwebengine
Alpine:v3.19
before 6.6.1-r11
6.6.1-r11
qt6-qtwebengine
Alpine:v3.20
before 6.6.3-r3
6.6.3-r3
qt6-qtwebengine
Alpine:v3.21
before 6.6.3-r3
6.6.3-r3
qt6-qtwebengine
Alpine:v3.22
before 6.6.3-r3
6.6.3-r3
qt6-qtwebengine
Alpine:v3.23
before 6.6.3-r3
6.6.3-r3
qt6-qtwebengine
Alpine:v3.24
before 6.6.3-r3
6.6.3-r3
Show 6 moreShow less
Affected packages
PackageAffectedFixed
chromium
Debian:12
before 124.0.6367.78-1~deb12u1, plus listed versions
113.0.5672.126-1114.0.5735.106-1114.0.5735.106-1~deb11u1114.0.5735.106-1~deb12u1114.0.5735.133-1
Show 45 moreShow less
114.0.5735.133-1~deb11u1114.0.5735.133-1~deb12u1114.0.5735.198-1114.0.5735.198-1~deb11u1114.0.5735.198-1~deb12u1114.0.5735.90-1114.0.5735.90-2114.0.5735.90-2~deb11u1114.0.5735.90-2~deb12u1115.0.5790.102-1115.0.5790.102-2115.0.5790.170-1115.0.5790.170-1~deb11u1115.0.5790.170-1~deb12u1115.0.5790.98-1115.0.5790.98-1~deb11u1115.0.5790.98-1~deb12u1115.0.5790.98-2116.0.5845.110-1116.0.5845.110-1~deb11u1116.0.5845.110-1~deb12u1116.0.5845.110-2116.0.5845.140-1116.0.5845.140-1~deb11u1116.0.5845.140-1~deb12u1116.0.5845.180-1116.0.5845.180-1~deb11u1116.0.5845.180-1~deb12u1116.0.5845.96-1116.0.5845.96-1~deb11u1116.0.5845.96-1~deb12u1116.0.5845.96-2117.0.5938.132-1117.0.5938.132-1~deb11u1117.0.5938.132-1~deb12u1117.0.5938.132-2117.0.5938.149-1117.0.5938.149-1~deb11u1117.0.5938.149-1~deb12u1117.0.5938.62-1117.0.5938.62-1~deb11u1117.0.5938.62-1~deb12u1117.0.5938.92-1118.0.5993.117-1118.0.5993.117-1~deb11u1
124.0.6367.78-1~deb12u1
chromium
Debian:13
before 124.0.6367.78-1
124.0.6367.78-1
chromium
Debian:14
before 124.0.6367.78-1
124.0.6367.78-1
nodejs-electron
openSUSE:Tumbleweed
before 29.3.2~20240430g19f0abd6-1.1
29.3.2~20240430g19f0abd6-1.1
chromium
openSUSE:Tumbleweed
before 124.0.6367.201-1.1
124.0.6367.201-1.1
libqt5-qtwebengine
openSUSE:Tumbleweed
before 5.15.18-1.1
5.15.18-1.1

History

History
RecordedChangedSources
affected, aliases, referencesOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-4058 is a high vulnerability (CVSS 8.8) in Google Chrome, published April 26, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 8.83%, the 95th percentile. Fixed in qt5-qtwebengine 5.15.16-r9.

References

Show 57 moreShow less
This page doesn't list everything

Left out here: 61 versions. The JSON record has them.

MoveEnter Open