CVE-2024-5157
Use after free in Scheduling in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to...
Use after free in Scheduling in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page. (Chromium security severity: High)
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
Use after free in Scheduling in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page. (Chromium security severity: High)
- Record
CVE-2024-5157- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
CVE List
8.8
Use after free in Scheduling in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page. (Chromium security severity: High)
- Record
CVE-2024-5157- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
EUVDEUVD-2024-46408
8.8
Use after free in Scheduling in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page. (Chromium security severity: High)
- Record
EUVD-2024-46408- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-w7g4-69hj-jcrq
8.8
Use after free in Scheduling in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to...
Use after free in Scheduling in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page. (Chromium security severity: High)
- Record
GHSA-w7g4-69hj-jcrq- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
OSVALPINE-CVE-2024-5157
8.8
Use after free in Scheduling in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page. (Chromium security severity: High)
- Record
ALPINE-CVE-2024-5157- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSV
8.8
Use after free in Scheduling in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page. (Chromium security severity: High)
- Record
CVE-2024-5157- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2024-5157
8.8
Use after free in Scheduling in Google Chrome prior to 125.0.6422.76 allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page. (Chromium security severity: High)
- Record
DEBIAN-CVE-2024-5157- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2024-0194 No score
Updated chromium-browser-stable packages fix security vulnerabilities
The chromium-browser-stable package has been updated to the 125.0.6422.76 release. It includes 6 security fixes Please, do note, that since some versions ago, only x86_64 is supported. i586 support for linux was stopped some years ago and the community is not able to provide patches anymore for the latest Chromium code.. High CVE-2024-5157: Use after free in Scheduling. High CVE-2024-5158: Type Confusion in V8. High CVE-2024-5159: Heap buffer overflow in ANGLE. High CVE-2024-5160: Heap buffer overflow in Dawn.
- Record
MGASA-2024-0194- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:0137-1 No score
Security update for chromium
This update for chromium fixes the following issues:
- Chromium 125.0.6422.76 (boo#1224818)
- CVE-2024-5157: Use after free in Scheduling
- CVE-2024-5158: Type Confusion in V8
- CVE-2024-5159: Heap buffer overflow in ANGLE
- CVE-2024-5160: Heap buffer overflow in Dawn
- Various fixes from internal audits, fuzzing and other initiatives
- Record
openSUSE-SU-2024:0137-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:13988-1 No score
chromedriver-125.0.6422.76-1.1 on GA media
These are all security issues fixed in the chromedriver-125.0.6422.76-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:13988-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
qt6-qtwebengineAlpine:v3.21 |
before 6.7.2-r5 | 6.7.2-r5 |
qt6-qtwebengineAlpine:v3.22 |
before 6.7.2-r5 | 6.7.2-r5 |
qt6-qtwebengineAlpine:v3.23 |
before 6.7.2-r5 | 6.7.2-r5 |
qt6-qtwebengineAlpine:v3.24 |
before 6.7.2-r5 | 6.7.2-r5 |
chromiumDebian:12 |
before 125.0.6422.76-1~deb12u1, plus listed versions 113.0.5672.126-1114.0.5735.106-1114.0.5735.106-1~deb11u1114.0.5735.106-1~deb12u1114.0.5735.133-1 Show 45 moreShow less114.0.5735.133-1~deb11u1114.0.5735.133-1~deb12u1114.0.5735.198-1114.0.5735.198-1~deb11u1114.0.5735.198-1~deb12u1114.0.5735.90-1114.0.5735.90-2114.0.5735.90-2~deb11u1114.0.5735.90-2~deb12u1115.0.5790.102-1115.0.5790.102-2115.0.5790.170-1115.0.5790.170-1~deb11u1115.0.5790.170-1~deb12u1115.0.5790.98-1115.0.5790.98-1~deb11u1115.0.5790.98-1~deb12u1115.0.5790.98-2116.0.5845.110-1116.0.5845.110-1~deb11u1116.0.5845.110-1~deb12u1116.0.5845.110-2116.0.5845.140-1116.0.5845.140-1~deb11u1116.0.5845.140-1~deb12u1116.0.5845.180-1116.0.5845.180-1~deb11u1116.0.5845.180-1~deb12u1116.0.5845.96-1116.0.5845.96-1~deb11u1116.0.5845.96-1~deb12u1116.0.5845.96-2117.0.5938.132-1117.0.5938.132-1~deb11u1117.0.5938.132-1~deb12u1117.0.5938.132-2117.0.5938.149-1117.0.5938.149-1~deb11u1117.0.5938.149-1~deb12u1117.0.5938.62-1117.0.5938.62-1~deb11u1117.0.5938.62-1~deb12u1117.0.5938.92-1118.0.5993.117-1118.0.5993.117-1~deb11u1 |
125.0.6422.76-1~deb12u1 |
chromiumDebian:13 |
before 125.0.6422.76-1 | 125.0.6422.76-1 |
chromiumDebian:14 |
before 125.0.6422.76-1 | 125.0.6422.76-1 |
chromium-browser-stableMageia:9 |
before 125.0.6422.76-1.mga9.tainted | 125.0.6422.76-1.mga9.tainted |
chromiumSUSE:Package Hub 15 SP5 |
before 125.0.6422.76-bp155.2.85.2 | 125.0.6422.76-bp155.2.85.2 |
chromiumopenSUSE:Leap 15.5 |
before 125.0.6422.76-bp155.2.85.2 | 125.0.6422.76-bp155.2.85.2 |
chromiumopenSUSE:Tumbleweed |
before 125.0.6422.76-1.1 | 125.0.6422.76-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, references | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-5157 is a high vulnerability (CVSS 8.8) in Google Chrome, published May 22, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.78%, the 56th percentile. Fixed in qt6-qtwebengine 6.7.2-r5.
References
chromereleases.googleblog.com/2024/05/stable-channel-update-for-desktop_21.html
issues.chromium.org/issues/336012573
lists.fedoraproject.org/archives/list/[email protected]/message/5KEVD4433KTOCYY6V4I7MMYKQ6URUS4L
lists.fedoraproject.org/archives/list/[email protected]/message/FX6IYZ6XF7B2WE66NFPNI2NHWJFI6VDF
nvd.nist.gov/vuln/detail/CVE-2024-5157
github.com/advisories/GHSA-w7g4-69hj-jcrq
Show 10 moreShow less
security.alpinelinux.org/vuln/CVE-2024-5157
security-tracker.debian.org/tracker/CVE-2024-5157
advisories.mageia.org/MGASA-2024-0194.html
bugs.mageia.org/show_bug.cgi?id=33231
lists.opensuse.org/archives/list/[email protected]/thread/OUHQT3H7SVUMWPOBHPV62RCKTAJROHUB
bugzilla.suse.com/1224818
suse.com/security/cve/CVE-2024-5157
suse.com/security/cve/CVE-2024-5158
suse.com/security/cve/CVE-2024-5159
suse.com/security/cve/CVE-2024-5160
Left out here: 73 versions. The JSON record has them.