Every CVE Search/ Get API key

CVE-2004-0916

Directory traversal vulnerability in cabextract before 1.1 allows remote attackers to overwrite...

5.0 MediumFix available

Directory traversal vulnerability in cabextract before 1.1 allows remote attackers to overwrite arbitrary files via a cabinet file containing .. (dot dot) sequences in a filename.

Exploit likelihood

3.59%Up 2.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Directory traversal vulnerability in cabextract before 1.1 allows remote attackers to overwrite arbitrary files via a cabinet file containing .. (dot dot) sequences in a filename.

Record
CVE-2004-0916
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

Directory traversal vulnerability in cabextract before 1.1 allows remote attackers to overwrite arbitrary files via a cabinet file containing .. (dot dot) sequences in a filename.

Record
CVE-2004-0916
Updated
2026-11-02
EUVDEUVD-2004-0914 No score

Directory traversal vulnerability in cabextract before 1.1 allows remote attackers to overwrite arbitrary files via a cabinet file containing .. (dot dot) sequences in a filename.

Record
EUVD-2004-0914
Updated
2026-11-03
GitHub AdvisoriesGHSA-3c6r-mr2w-qgv5 No score

Directory traversal vulnerability in cabextract before 1.1 allows remote attackers to overwrite...

Directory traversal vulnerability in cabextract before 1.1 allows remote attackers to overwrite arbitrary files via a cabinet file containing .. (dot dot) sequences in a filename.

Record
GHSA-3c6r-mr2w-qgv5
Updated
2026-11-02
OSV No score

Directory traversal vulnerability in cabextract before 1.1 allows remote attackers to overwrite arbitrary files via a cabinet file containing .. (dot dot) sequences in a filename.

Record
CVE-2004-0916
Updated
2026-11-02
OSVDEBIAN-CVE-2004-0916 No score

Directory traversal vulnerability in cabextract before 1.1 allows remote attackers to overwrite arbitrary files via a cabinet file containing .. (dot dot) sequences in a filename.

Record
DEBIAN-CVE-2004-0916
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cabextract
Debian:12
before 1.1-1
1.1-1
cabextract
Debian:13
before 1.1-1
1.1-1
cabextract
Debian:14
before 1.1-1
1.1-1
cabextract
Debian:3.0
before 0.2-2b
0.2-2b

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0916 is a medium vulnerability (CVSS 5.0) in Cabextract Project Cabextract, published October 28, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.59%, the 89th percentile. Fixed in cabextract 1.1-1.

References

MoveEnter Open