Every CVE Search/ Get API key

CVE-2004-1170

a2ps 4.13 allows remote attackers to execute arbitrary commands via shell metacharacters in the...

10.0 HighPublic exploitFix available

a2ps 4.13 allows remote attackers to execute arbitrary commands via shell metacharacters in the filename.

Exploit likelihood

16.0%Up 3.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

a2ps 4.13 allows remote attackers to execute arbitrary commands via shell metacharacters in the filename.

Record
CVE-2004-1170
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

a2ps 4.13 allows remote attackers to execute arbitrary commands via shell metacharacters in the filename.

Record
CVE-2004-1170
Updated
2026-11-02
EUVDEUVD-2004-1168 No score

a2ps 4.13 allows remote attackers to execute arbitrary commands via shell metacharacters in the filename.

Record
EUVD-2004-1168
Updated
2026-11-03
GitHub AdvisoriesGHSA-6hxv-9334-gpvg No score

a2ps 4.13 allows remote attackers to execute arbitrary commands via shell metacharacters in the...

a2ps 4.13 allows remote attackers to execute arbitrary commands via shell metacharacters in the filename.

Record
GHSA-6hxv-9334-gpvg
Updated
2026-11-02
OSV No score

a2ps 4.13 allows remote attackers to execute arbitrary commands via shell metacharacters in the filename.

Record
CVE-2004-1170
Updated
2026-11-02
OSVDEBIAN-CVE-2004-1170 No score

a2ps 4.13 allows remote attackers to execute arbitrary commands via shell metacharacters in the filename.

Record
DEBIAN-CVE-2004-1170
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
a2ps
Debian:12
before 1:4.13b-4.2
1:4.13b-4.2
a2ps
Debian:13
before 1:4.13b-4.2
1:4.13b-4.2
a2ps
Debian:14
before 1:4.13b-4.2
1:4.13b-4.2
a2ps
Debian:3.0
before 1:4.13b-4.2, plus listed versions
4.13b-16woody1
1:4.13b-4.2

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBGNU a2ps 4.13 - File Name Command Execution2004-08-24

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-1170 is a high vulnerability (CVSS 10.0) in Gnu A2ps, published December 10, 2004. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 16.0%, the 96th percentile. Fixed in a2ps 1:4.13b-4.2.

References

Show 8 moreShow less
MoveEnter Open