Every CVE Search/ Get API key

CVE-2005-0015

diatheke.pl in Sword 1.5.7a allows remote attackers to execute arbitrary commands via shell...

7.5 HighFix available

diatheke.pl in Sword 1.5.7a allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.

Exploit likelihood

2.26%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

diatheke.pl in Sword 1.5.7a allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.

Record
CVE-2005-0015
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

diatheke.pl in Sword 1.5.7a allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.

Record
CVE-2005-0015
Updated
2026-11-02
EUVDEUVD-2005-0016 No score

diatheke.pl in Sword 1.5.7a allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.

Record
EUVD-2005-0016
Updated
2026-11-03
GitHub AdvisoriesGHSA-fp44-79vr-grcq No score

diatheke.pl in Sword 1.5.7a allows remote attackers to execute arbitrary commands via shell...

diatheke.pl in Sword 1.5.7a allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.

Record
GHSA-fp44-79vr-grcq
Updated
2026-11-02
OSV No score

diatheke.pl in Sword 1.5.7a allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.

Record
CVE-2005-0015
Updated
2026-11-02
OSVDEBIAN-CVE-2005-0015 No score

diatheke.pl in Sword 1.5.7a allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.

Record
DEBIAN-CVE-2005-0015
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
sword
Debian:12
before 1.5.7-7
1.5.7-7
sword
Debian:13
before 1.5.7-7
1.5.7-7
sword
Debian:14
before 1.5.7-7
1.5.7-7
sword
Debian:3.0
before 1.5.3-3woody2, plus listed versions
1.5.3-3
1.5.3-3woody2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-0015 is a high vulnerability (CVSS 7.5) in Crosswire Bible Society Sword, published January 20, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.26%, the 83rd percentile. Fixed in sword 1.5.7-7.

References

MoveEnter Open