Every CVE Search/ Get API key

CVE-2005-1920

The (1) Kate and (2) Kwrite applications in KDE KDE 3.2.x through 3.4.0 do not properly set the...

7.5 HighFix available

The (1) Kate and (2) Kwrite applications in KDE KDE 3.2.x through 3.4.0 do not properly set the same permissions on the backup file as were set on the original file, which could allow local users and possibly remote attackers to obtain sensitive information.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

3.67%Up 1.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The (1) Kate and (2) Kwrite applications in KDE KDE 3.2.x through 3.4.0 do not properly set the same permissions on the backup file as were set on the original file, which could allow local users and possibly remote attackers to obtain sensitive information.

Record
CVE-2005-1920
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-281
Updated
2026-11-02
CVE List No score

The (1) Kate and (2) Kwrite applications in KDE KDE 3.2.x through 3.4.0 do not properly set the same permissions on the backup file as were set on the original file, which could allow local users and possibly remote attackers to obtain sensitive information.

Record
CVE-2005-1920
Updated
2026-11-02
EUVDEUVD-2005-1922 No score

The (1) Kate and (2) Kwrite applications in KDE KDE 3.2.x through 3.4.0 do not properly set the same permissions on the backup file as were set on the original file, which could allow local users and possibly remote attackers to obtain sensitive information.

Record
EUVD-2005-1922
Updated
2026-11-03
GitHub AdvisoriesGHSA-2p38-wq56-wg8h 7.5

The (1) Kate and (2) Kwrite applications in KDE KDE 3.2.x through 3.4.0 do not properly set the...

The (1) Kate and (2) Kwrite applications in KDE KDE 3.2.x through 3.4.0 do not properly set the same permissions on the backup file as were set on the original file, which could allow local users and possibly remote attackers to obtain sensitive information.

Record
GHSA-2p38-wq56-wg8h
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-281
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
kdelibs
Debian:3.1
before 4:3.3.2-6.3, plus listed versions
4:3.3.2-6.14:3.3.2-6.2
4:3.3.2-6.3
kdelibs
Red Hat:enterprise_linux:4::as
before 6:3.3.1-3.11
6:3.3.1-3.11
kdelibs-debuginfo
Red Hat:enterprise_linux:4::as
before 6:3.3.1-3.11
6:3.3.1-3.11
kdelibs-devel
Red Hat:enterprise_linux:4::as
before 6:3.3.1-3.11
6:3.3.1-3.11
kdelibs
Red Hat:enterprise_linux:4::desktop
before 6:3.3.1-3.11
6:3.3.1-3.11
kdelibs-debuginfo
Red Hat:enterprise_linux:4::desktop
before 6:3.3.1-3.11
6:3.3.1-3.11
kdelibs-devel
Red Hat:enterprise_linux:4::desktop
before 6:3.3.1-3.11
6:3.3.1-3.11
kdelibs
Red Hat:enterprise_linux:4::es
before 6:3.3.1-3.11
6:3.3.1-3.11
kdelibs-debuginfo
Red Hat:enterprise_linux:4::es
before 6:3.3.1-3.11
6:3.3.1-3.11
kdelibs-devel
Red Hat:enterprise_linux:4::es
before 6:3.3.1-3.11
6:3.3.1-3.11
kdelibs
Red Hat:enterprise_linux:4::ws
before 6:3.3.1-3.11
6:3.3.1-3.11
kdelibs-debuginfo
Red Hat:enterprise_linux:4::ws
before 6:3.3.1-3.11
6:3.3.1-3.11
kdelibs-devel
Red Hat:enterprise_linux:4::ws
before 6:3.3.1-3.11
6:3.3.1-3.11

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-1920 is a high vulnerability (CVSS 7.5) in Kde, published July 26, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.67%, the 89th percentile. Fixed in kdelibs 4:3.3.2-6.3.

References

Show 15 moreShow less
MoveEnter Open