Every CVE Search/ Get API key

CVE-2005-2966

The Python SVG import plugin (diasvg_import.py) for DIA 0.94 and earlier allows user-assisted...

5.1 MediumFix available

The Python SVG import plugin (diasvg_import.py) for DIA 0.94 and earlier allows user-assisted attackers to execute arbitrary commands via a crafted SVG file.

Exploit likelihood

2.61%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.1

The Python SVG import plugin (diasvg_import.py) for DIA 0.94 and earlier allows user-assisted attackers to execute arbitrary commands via a crafted SVG file.

Record
CVE-2005-2966
CVSS 2.0
5.1 MediumAV:N/AC:H/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

The Python SVG import plugin (diasvg_import.py) for DIA 0.94 and earlier allows user-assisted attackers to execute arbitrary commands via a crafted SVG file.

Record
CVE-2005-2966
Updated
2026-11-02
EUVDEUVD-2005-2966 No score

The Python SVG import plugin (diasvg_import.py) for DIA 0.94 and earlier allows user-assisted attackers to execute arbitrary commands via a crafted SVG file.

Record
EUVD-2005-2966
Updated
2026-11-03
GitHub AdvisoriesGHSA-2w7x-w5p4-w2mw No score

The Python SVG import plugin (diasvg_import.py) for DIA 0.94 and earlier allows user-assisted...

The Python SVG import plugin (diasvg_import.py) for DIA 0.94 and earlier allows user-assisted attackers to execute arbitrary commands via a crafted SVG file.

Record
GHSA-2w7x-w5p4-w2mw
Updated
2026-11-02
OSV No score

The Python SVG import plugin (diasvg_import.py) for DIA 0.94 and earlier allows user-assisted attackers to execute arbitrary commands via a crafted SVG file.

Record
CVE-2005-2966
Updated
2026-11-02
OSVDEBIAN-CVE-2005-2966 No score

The Python SVG import plugin (diasvg_import.py) for DIA 0.94 and earlier allows user-assisted attackers to execute arbitrary commands via a crafted SVG file.

Record
DEBIAN-CVE-2005-2966
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
dia
Debian:12
before 0.94.0-15
0.94.0-15
dia
Debian:13
before 0.94.0-15
0.94.0-15
dia
Debian:14
before 0.94.0-15
0.94.0-15
dia
Debian:3.1
before 0.94.0-7sarge1, plus listed versions
0.94.0-7
0.94.0-7sarge1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-2966 is a medium vulnerability (CVSS 5.1) in Dia, published October 5, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.61%, the 85th percentile. Fixed in dia 0.94.0-15.

References

Show 10 moreShow less
MoveEnter Open