Every CVE Search/ Get API key

CVE-2006-0301

Heap-based buffer overflow in Splash.cc in xpdf, as used in other products such as (1) poppler, ...

7.5 HighFix available

Heap-based buffer overflow in Splash.cc in xpdf, as used in other products such as (1) poppler, (2) kdegraphics, (3) gpdf, (4) pdfkit.framework, and others, allows attackers to cause a denial of service and possibly execute arbitrary code via crafted splash images that produce certain values that exceed the width or height of the associated bitmap.

Exploit likelihood

4.51%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Heap-based buffer overflow in Splash.cc in xpdf, as used in other products such as (1) poppler, (2) kdegraphics, (3) gpdf, (4) pdfkit.framework, and others, allows attackers to cause a denial of service and possibly execute arbitrary code via crafted splash images that produce certain values that exceed the width or height of the associated bitmap.

Record
CVE-2006-0301
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in Splash.cc in xpdf, as used in other products such as (1) poppler, (2) kdegraphics, (3) gpdf, (4) pdfkit.framework, and others, allows attackers to cause a denial of service and possibly execute arbitrary code via crafted splash images that produce certain values that exceed the width or height of the associated bitmap.

Record
CVE-2006-0301
Updated
2026-11-02
EUVDEUVD-2006-0308 No score

Heap-based buffer overflow in Splash.cc in xpdf, as used in other products such as (1) poppler, (2) kdegraphics, (3) gpdf, (4) pdfkit.framework, and others, allows attackers to cause a denial of service and possibly execute arbitrary code via crafted splash images that produce certain values that exceed the width or height of the associated bitmap.

Record
EUVD-2006-0308
Updated
2026-11-03
GitHub AdvisoriesGHSA-rj3h-g34f-3227 No score

Heap-based buffer overflow in Splash.cc in xpdf, as used in other products such as (1) poppler, ...

Heap-based buffer overflow in Splash.cc in xpdf, as used in other products such as (1) poppler, (2) kdegraphics, (3) gpdf, (4) pdfkit.framework, and others, allows attackers to cause a denial of service and possibly execute arbitrary code via crafted splash images that produce certain values that exceed the width or height of the associated bitmap.

Record
GHSA-rj3h-g34f-3227
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Heap-based buffer overflow in Splash.cc in xpdf, as used in other products such as (1) poppler, (2) kdegraphics, (3) gpdf, (4) pdfkit.framework, and others, allows attackers to cause a denial of service and possibly execute arbitrary code via crafted splash images that produce certain values that exceed the width or height of the associated bitmap.

Record
CVE-2006-0301
Updated
2026-11-02
OSVDEBIAN-CVE-2006-0301 No score

Heap-based buffer overflow in Splash.cc in xpdf, as used in other products such as (1) poppler, (2) kdegraphics, (3) gpdf, (4) pdfkit.framework, and others, allows attackers to cause a denial of service and possibly execute arbitrary code via crafted splash images that produce certain values that exceed the width or height of the associated bitmap.

Record
DEBIAN-CVE-2006-0301
Updated
2026-11-02
OSVopenSUSE-SU-2024:11181-1 No score

libpoppler-cpp0-21.08.0-1.3 on GA media

These are all security issues fixed in the libpoppler-cpp0-21.08.0-1.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11181-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libextractor
Debian:12
before 0.5.10-1
0.5.10-1
libextractor
Debian:13
before 0.5.10-1
0.5.10-1
libextractor
Debian:14
before 0.5.10-1
0.5.10-1
poppler
Debian:12
before 0.4.5-1
0.4.5-1
poppler
Debian:13
before 0.4.5-1
0.4.5-1
poppler
Debian:14
before 0.4.5-1
0.4.5-1
xpdf
Debian:12
before 3.01-6
3.01-6
xpdf
Debian:13
before 3.01-6
3.01-6
xpdf
Debian:14
before 3.01-6
3.01-6
koffice
Debian:3.1
From an advisory covering 3 CVEs
before 1.3.5-4.sarge.3
1.3.5-4.sarge.3
Show 29 moreShow less
Affected packages
PackageAffectedFixed
xpdf
Debian:3.1
before 3.00-13.5, plus listed versions
3.00-133.00-13.13.00-13.23.00-13.33.00-13.4
3.00-13.5
pdfkit.framework
Debian:3.1
before 0.8-2sarge2, plus listed versions
0.8-20.8-2sarge1
0.8-2sarge2
gpdf
Debian:3.1
before 2.8.2-1.2sarge3, plus listed versions
2.8.2-1.22.8.2-1.2sarge12.8.2-1.2sarge2
2.8.2-1.2sarge3
pdfkit.framework
Debian:3.1
From an advisory covering 3 CVEs
before 0.8-2sarge3, plus listed versions
0.8-20.8-2sarge10.8-2sarge2
0.8-2sarge3
gpdf
Debian:3.1
From an advisory covering 5 CVEs
before 2.8.2-1.2sarge4, plus listed versions
2.8.2-1.22.8.2-1.2sarge12.8.2-1.2sarge22.8.2-1.2sarge3
2.8.2-1.2sarge4
pdftohtml
Debian:3.1
From an advisory covering 3 CVEs
before 0.36-11sarge2, plus listed versions
0.36-110.36-11sarge1
0.36-11sarge2
xpdf
Debian:3.1
From an advisory covering 4 CVEs
before 3.00-13.6, plus listed versions
3.00-133.00-13.13.00-13.23.00-13.33.00-13.43.00-13.5
3.00-13.6
libextractor
Debian:3.1
before 0.4.2-2sarge3, plus listed versions
0.4.2-20.4.2-2sarge10.4.2-2sarge2
0.4.2-2sarge3
xpdf
Red Hat:enterprise_linux:4::as
before 1:3.00-11.12
1:3.00-11.12
xpdf-debuginfo
Red Hat:enterprise_linux:4::as
before 1:3.00-11.12
1:3.00-11.12
xpdf
Red Hat:enterprise_linux:4::desktop
before 1:3.00-11.12
1:3.00-11.12
xpdf-debuginfo
Red Hat:enterprise_linux:4::desktop
before 1:3.00-11.12
1:3.00-11.12
xpdf
Red Hat:enterprise_linux:4::es
before 1:3.00-11.12
1:3.00-11.12
xpdf-debuginfo
Red Hat:enterprise_linux:4::es
before 1:3.00-11.12
1:3.00-11.12
xpdf
Red Hat:enterprise_linux:4::ws
before 1:3.00-11.12
1:3.00-11.12
xpdf-debuginfo
Red Hat:enterprise_linux:4::ws
before 1:3.00-11.12
1:3.00-11.12
kdegraphics
Red Hat:enterprise_linux:4::as
before 7:3.3.1-3.7
7:3.3.1-3.7
kdegraphics-debuginfo
Red Hat:enterprise_linux:4::as
before 7:3.3.1-3.7
7:3.3.1-3.7
kdegraphics-devel
Red Hat:enterprise_linux:4::as
before 7:3.3.1-3.7
7:3.3.1-3.7
kdegraphics
Red Hat:enterprise_linux:4::desktop
before 7:3.3.1-3.7
7:3.3.1-3.7
kdegraphics-debuginfo
Red Hat:enterprise_linux:4::desktop
before 7:3.3.1-3.7
7:3.3.1-3.7
kdegraphics-devel
Red Hat:enterprise_linux:4::desktop
before 7:3.3.1-3.7
7:3.3.1-3.7
kdegraphics
Red Hat:enterprise_linux:4::es
before 7:3.3.1-3.7
7:3.3.1-3.7
kdegraphics-debuginfo
Red Hat:enterprise_linux:4::es
before 7:3.3.1-3.7
7:3.3.1-3.7
kdegraphics-devel
Red Hat:enterprise_linux:4::es
before 7:3.3.1-3.7
7:3.3.1-3.7
kdegraphics
Red Hat:enterprise_linux:4::ws
before 7:3.3.1-3.7
7:3.3.1-3.7
kdegraphics-debuginfo
Red Hat:enterprise_linux:4::ws
before 7:3.3.1-3.7
7:3.3.1-3.7
kdegraphics-devel
Red Hat:enterprise_linux:4::ws
before 7:3.3.1-3.7
7:3.3.1-3.7
poppler
openSUSE:Tumbleweed
From an advisory covering 9 CVEs
before 21.08.0-1.3
21.08.0-1.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-0301 is a high vulnerability (CVSS 7.5) in Xpdf, published January 30, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.51%, the 91st percentile. Fixed in libextractor 0.5.10-1.

References

Show 60 moreShow less
MoveEnter Open