CVE-2008-3546
Stack-based buffer overflow in the (1) diff_addremove and (2) diff_change functions in GIT before...
CVE-2008-3546 is a high vulnerability (CVSS 7.5) in Git, published August 7, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.30%, the 91st percentile. Fixed in git-core 1:1.4.4.4-2.1+etch1.
Stack-based buffer overflow in the (1) diff_addremove and (2) diff_change functions in GIT before 1.5.6.4 might allow local users to execute arbitrary code via a PATH whose length is larger than the system's PATH_MAX when running GIT utilities such as git-diff or git-grep.
Exploit likelihood
What each source reports
NVD Score used
7.5
Stack-based buffer overflow in the (1) diff_addremove and (2) diff_change functions in GIT before 1.5.6.4 might allow local users to execute arbitrary code via a PATH whose length is larger than the system's PATH_MAX when running GIT utilities such as git-diff or git-grep.
- Record
CVE-2008-3546- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Stack-based buffer overflow in the (1) diff_addremove and (2) diff_change functions in GIT before 1.5.6.4 might allow local users to execute arbitrary code via a PATH whose length is larger than the system's PATH_MAX when running GIT utilities such as git-diff or git-grep.
- Record
CVE-2008-3546- Updated
- 2026-11-02
EUVDEUVD-2008-3532 No score
Stack-based buffer overflow in the (1) diff_addremove and (2) diff_change functions in GIT before 1.5.6.4 might allow local users to execute arbitrary code via a PATH whose length is larger than the system's PATH_MAX when running GIT utilities such as git-diff or git-grep.
- Record
EUVD-2008-3532- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-j9cr-wr26-g3fp No score
Stack-based buffer overflow in the (1) diff_addremove and (2) diff_change functions in GIT before...
Stack-based buffer overflow in the (1) diff_addremove and (2) diff_change functions in GIT before 1.5.6.4 might allow local users to execute arbitrary code via a PATH whose length is larger than the system's PATH_MAX when running GIT utilities such as git-diff or git-grep.
- Record
GHSA-j9cr-wr26-g3fp- Weakness
- CWE-119
- Updated
- 2026-11-02
Affected products
Affected packages
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
securityfocus.com/archive/1/495391/100/0/threaded
kernel.org/pub/software/scm/git/docs/RelNotes-1.5.6.4.txt
secunia.com/advisories/32029
wiki.rpath.com/Advisories:rPSA-2008-0253
exchange.xforce.ibmcloud.com/vulnerabilities/44217
secunia.com/advisories/33964
Show 14 moreShow less
issues.rpath.com/browse/RPL-2707
secunia.com/advisories/31347
security.gentoo.org/glsa/glsa-200809-16.xml
debian.org/security/2008/dsa-1637
kerneltrap.org/mailarchive/git/2008/7/16/2529284
redhat.com/archives/fedora-package-announce/2008-October/msg00729.html
secunia.com/advisories/32384
securityfocus.com/bid/30549
vupen.com/english/advisories/2008/2306
securitytracker.com/id?1020627
secunia.com/advisories/31780
ubuntu.com/usn/USN-723-1
nvd.nist.gov/vuln/detail/CVE-2008-3546
github.com/advisories/GHSA-j9cr-wr26-g3fp