Every CVE Search/ Get API key

CVE-2008-2380

SQL injection vulnerability in authpgsqllib.c in Courier-Authlib before 0.62.0, when a non-Latin...

5.1 MediumFix available

SQL injection vulnerability in authpgsqllib.c in Courier-Authlib before 0.62.0, when a non-Latin locale Postgres database is used, allows remote attackers to execute arbitrary SQL commands via query parameters containing apostrophes.

Exploit likelihood

1.82%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.1

SQL injection vulnerability in authpgsqllib.c in Courier-Authlib before 0.62.0, when a non-Latin locale Postgres database is used, allows remote attackers to execute arbitrary SQL commands via query parameters containing apostrophes.

Record
CVE-2008-2380
CVSS 2.0
5.1 MediumAV:N/AC:H/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

SQL injection vulnerability in authpgsqllib.c in Courier-Authlib before 0.62.0, when a non-Latin locale Postgres database is used, allows remote attackers to execute arbitrary SQL commands via query parameters containing apostrophes.

Record
CVE-2008-2380
Updated
2026-11-02
EUVDEUVD-2008-2375 No score

SQL injection vulnerability in authpgsqllib.c in Courier-Authlib before 0.62.0, when a non-Latin locale Postgres database is used, allows remote attackers to execute arbitrary SQL commands via query parameters containing apostrophes.

Record
EUVD-2008-2375
Updated
2026-11-03
GitHub AdvisoriesGHSA-p4v2-gpr7-p49q No score

SQL injection vulnerability in authpgsqllib.c in Courier-Authlib before 0.62.0, when a non-Latin...

SQL injection vulnerability in authpgsqllib.c in Courier-Authlib before 0.62.0, when a non-Latin locale Postgres database is used, allows remote attackers to execute arbitrary SQL commands via query parameters containing apostrophes.

Record
GHSA-p4v2-gpr7-p49q
Weakness
CWE-89
Updated
2026-11-02
OSV No score

SQL injection vulnerability in authpgsqllib.c in Courier-Authlib before 0.62.0, when a non-Latin locale Postgres database is used, allows remote attackers to execute arbitrary SQL commands via query parameters containing apostrophes.

Record
CVE-2008-2380
Updated
2026-11-02
OSVDEBIAN-CVE-2008-2380 No score

SQL injection vulnerability in authpgsqllib.c in Courier-Authlib before 0.62.0, when a non-Latin locale Postgres database is used, allows remote attackers to execute arbitrary SQL commands via query parameters containing apostrophes.

Record
DEBIAN-CVE-2008-2380
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
courier-authlib
Debian:12
before 0.61.0-1+lenny1
0.61.0-1+lenny1
courier-authlib
Debian:13
before 0.61.0-1+lenny1
0.61.0-1+lenny1
courier-authlib
Debian:14
before 0.61.0-1+lenny1
0.61.0-1+lenny1
courier-authlib
Debian:4.0
From an advisory covering 2 CVEs
before 0.58-4+etch2, plus listed versions
0.58-4
0.58-4+etch2
courier-authlib
Debian:5.0
before 0.61.0-1+lenny1
0.61.0-1+lenny1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-2380 is a medium vulnerability (CVSS 5.1) in Courier-mta Courtier-authlib, published December 19, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.82%, the 78th percentile. Fixed in courier-authlib 0.61.0-1+lenny1.

References

Show 4 moreShow less
MoveEnter Open