Every CVE Search/ Get API key

CVE-2007-5503

Multiple integer overflows in Cairo before 1.4.12 might allow remote attackers to execute...

6.8 MediumFix available

Multiple integer overflows in Cairo before 1.4.12 might allow remote attackers to execute arbitrary code, as demonstrated using a crafted PNG image with large width and height values, which is not properly handled by the read_png function.

Exploit likelihood

5.49%Down 6.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Multiple integer overflows in Cairo before 1.4.12 might allow remote attackers to execute arbitrary code, as demonstrated using a crafted PNG image with large width and height values, which is not properly handled by the read_png function.

Record
CVE-2007-5503
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Multiple integer overflows in Cairo before 1.4.12 might allow remote attackers to execute arbitrary code, as demonstrated using a crafted PNG image with large width and height values, which is not properly handled by the read_png function.

Record
CVE-2007-5503
Updated
2026-11-02
EUVDEUVD-2007-5478 No score

Multiple integer overflows in Cairo before 1.4.12 might allow remote attackers to execute arbitrary code, as demonstrated using a crafted PNG image with large width and height values, which is not properly handled by the read_png function.

Record
EUVD-2007-5478
Updated
2026-11-03
GitHub AdvisoriesGHSA-8cvg-h746-3fgp No score

Multiple integer overflows in Cairo before 1.4.12 might allow remote attackers to execute...

Multiple integer overflows in Cairo before 1.4.12 might allow remote attackers to execute arbitrary code, as demonstrated using a crafted PNG image with large width and height values, which is not properly handled by the read_png function.

Record
GHSA-8cvg-h746-3fgp
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libcairo
Debian:4.0
before 1.2.4-4.1+etch1, plus listed versions
1.2.4-4
1.2.4-4.1+etch1
libcairo
Debian:5.0
before 1.4.10-1+lenny2, plus listed versions
0.3.0-10.4.0-10.5.1-20.6.0-10.9.2-1
Show 36 moreShow less
0.9.2-21.0.0-11.0.0-21.0.0-31.0.2-11.0.2-21.0.2-31.0.4-0bpo11.0.4-11.0.4-1+b11.0.4-1+b21.0.4-1bpo11.0.4-21.0.4-2+b11.1.10-31.2.0-11.2.0-21.2.0-31.2.0-3+b11.2.0-41.2.0-51.2.2-11.2.4-11.2.4-21.2.4-31.2.4-3.11.2.4-3.21.2.4-41.2.4-4.1+etch11.2.6-11.4.10-11.4.2-11.4.4-11.4.6-11.4.6-1.11.4.8-1
1.4.10-1+lenny2
cairo
Red Hat:enterprise_linux:5::client_workstation
before 0:1.2.4-3.el5_1
0:1.2.4-3.el5_1
cairo-debuginfo
Red Hat:enterprise_linux:5::client_workstation
before 0:1.2.4-3.el5_1
0:1.2.4-3.el5_1
cairo-devel
Red Hat:enterprise_linux:5::client_workstation
before 0:1.2.4-3.el5_1
0:1.2.4-3.el5_1
cairo
Red Hat:enterprise_linux:5::client
before 0:1.2.4-3.el5_1
0:1.2.4-3.el5_1
cairo-debuginfo
Red Hat:enterprise_linux:5::client
before 0:1.2.4-3.el5_1
0:1.2.4-3.el5_1
cairo
Red Hat:enterprise_linux:5::server
before 0:1.2.4-3.el5_1
0:1.2.4-3.el5_1
cairo-debuginfo
Red Hat:enterprise_linux:5::server
before 0:1.2.4-3.el5_1
0:1.2.4-3.el5_1
cairo-devel
Red Hat:enterprise_linux:5::server
before 0:1.2.4-3.el5_1
0:1.2.4-3.el5_1

History

History
RecordedChangedSources
aliasesEUVD
affected, aliases, facts, references, titleGitHub Advisories, OSV
first indexedCVE List, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-5503 is a medium vulnerability (CVSS 6.8) in Redhat Cairo, published November 30, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.49%, the 92nd percentile. Fixed in libcairo 1.2.4-4.1+etch1.

References

Show 49 moreShow less
MoveEnter Open