CVE-2002-0972
Buffer overflows in PostgreSQL 7.2 allow attackers to cause a denial of service and possibly...
CVE-2002-0972 is a medium vulnerability (CVSS 4.6) in Postgresql, published August 23, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.49%, the 42nd percentile. Fixed in postgresql 7.2.1-2woody2.
Buffer overflows in PostgreSQL 7.2 allow attackers to cause a denial of service and possibly execute arbitrary code via long arguments to the functions (1) lpad or (2) rpad.
Exploit likelihood
What each source reports
NVD Score used
4.6
Buffer overflows in PostgreSQL 7.2 allow attackers to cause a denial of service and possibly execute arbitrary code via long arguments to the functions (1) lpad or (2) rpad.
- Record
CVE-2002-0972- CVSS 2.0
- 4.6 Medium
AV:L/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Buffer overflows in PostgreSQL 7.2 allow attackers to cause a denial of service and possibly execute arbitrary code via long arguments to the functions (1) lpad or (2) rpad.
- Record
CVE-2002-0972- Updated
- 2026-11-02
EUVDEUVD-2002-0961 No score
Buffer overflows in PostgreSQL 7.2 allow attackers to cause a denial of service and possibly execute arbitrary code via long arguments to the functions (1) lpad or (2) rpad.
- Record
EUVD-2002-0961- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m4fw-hwf8-whx3 No score
Buffer overflows in PostgreSQL 7.2 allow attackers to cause a denial of service and possibly...
Buffer overflows in PostgreSQL 7.2 allow attackers to cause a denial of service and possibly execute arbitrary code via long arguments to the functions (1) lpad or (2) rpad.
- Record
GHSA-m4fw-hwf8-whx3- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
postgresqlDebian:3.0 |
before 7.2.1-2woody2 | 7.2.1-2woody2 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |