Every CVE Search/ Get API key

CVE-2002-0983

IRC client irssi in irssi-text before 0.8.4 allows remote attackers to cause a denial of service ...

5.0 MediumFix available

IRC client irssi in irssi-text before 0.8.4 allows remote attackers to cause a denial of service (crash) via an IRC channel that has a long topic followed by a certain string, possibly triggering a buffer overflow.

Exploit likelihood

1.96%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

IRC client irssi in irssi-text before 0.8.4 allows remote attackers to cause a denial of service (crash) via an IRC channel that has a long topic followed by a certain string, possibly triggering a buffer overflow.

Record
CVE-2002-0983
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

IRC client irssi in irssi-text before 0.8.4 allows remote attackers to cause a denial of service (crash) via an IRC channel that has a long topic followed by a certain string, possibly triggering a buffer overflow.

Record
CVE-2002-0983
Updated
2026-11-02
EUVDEUVD-2002-0972 No score

IRC client irssi in irssi-text before 0.8.4 allows remote attackers to cause a denial of service (crash) via an IRC channel that has a long topic followed by a certain string, possibly triggering a buffer overflow.

Record
EUVD-2002-0972
Updated
2026-11-03
GitHub AdvisoriesGHSA-xrw3-7gpj-88wx No score

IRC client irssi in irssi-text before 0.8.4 allows remote attackers to cause a denial of service ...

IRC client irssi in irssi-text before 0.8.4 allows remote attackers to cause a denial of service (crash) via an IRC channel that has a long topic followed by a certain string, possibly triggering a buffer overflow.

Record
GHSA-xrw3-7gpj-88wx
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
irssi-text
Debian:3.0
before 0.8.4-3.1
0.8.4-3.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2002-0983 is a medium vulnerability (CVSS 5.0) in Irssi, published August 23, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.96%, the 80th percentile. Fixed in irssi-text 0.8.4-3.1.

References

MoveEnter Open