Every CVE Search/ Get API key

CVE-2002-1398

Buffer overflow in the date parser for PostgreSQL before 7.2.2 allows attackers to cause a denial...

4.6 MediumFix available

CVE-2002-1398 is a medium vulnerability (CVSS 4.6) in Postgresql, published September 12, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.54%, the 45th percentile. Fixed in postgresql 7.2.1-2woody2.

Buffer overflow in the date parser for PostgreSQL before 7.2.2 allows attackers to cause a denial of service and possibly execute arbitrary code via a long date string, aka a vulnerability "in handling long datetime input."

Exploit likelihood

0.54%Down 1.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.6

Buffer overflow in the date parser for PostgreSQL before 7.2.2 allows attackers to cause a denial of service and possibly execute arbitrary code via a long date string, aka a vulnerability "in handling long datetime input."

Record
CVE-2002-1398
CVSS 2.0
4.6 MediumAV:L/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Buffer overflow in the date parser for PostgreSQL before 7.2.2 allows attackers to cause a denial of service and possibly execute arbitrary code via a long date string, aka a vulnerability "in handling long datetime input."

Record
CVE-2002-1398
Updated
2026-11-02
EUVDEUVD-2002-1381 No score

Buffer overflow in the date parser for PostgreSQL before 7.2.2 allows attackers to cause a denial of service and possibly execute arbitrary code via a long date string, aka a vulnerability "in handling long datetime input."

Record
EUVD-2002-1381
Updated
2026-11-03
GitHub AdvisoriesGHSA-67pm-79gc-7qx9 No score

Buffer overflow in the date parser for PostgreSQL before 7.2.2 allows attackers to cause a denial...

Buffer overflow in the date parser for PostgreSQL before 7.2.2 allows attackers to cause a denial of service and possibly execute arbitrary code via a long date string, aka a vulnerability "in handling long datetime input."

Record
GHSA-67pm-79gc-7qx9
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
postgresql
Debian:3.0
before 7.2.1-2woody2
7.2.1-2woody2

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 6 moreShow less
MoveEnter Open