CVE-2002-1401
Buffer overflows in (1) circle_poly, (2) path_encode and (3) path_add (also incorrectly...
CVE-2002-1401 is a medium vulnerability (CVSS 6.5) in Postgresql, published September 12, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.19%, the 82nd percentile. Fixed in postgresql 7.2.1-2woody2.
Buffer overflows in (1) circle_poly, (2) path_encode and (3) path_add (also incorrectly identified as path_addr) for PostgreSQL 7.2.3 and earlier allow attackers to cause a denial of service and possibly execute arbitrary code, possibly as a result of an integer overflow.
Exploit likelihood
What each source reports
NVD Score used
6.5
Buffer overflows in (1) circle_poly, (2) path_encode and (3) path_add (also incorrectly identified as path_addr) for PostgreSQL 7.2.3 and earlier allow attackers to cause a denial of service and possibly execute arbitrary code, possibly as a result of an integer overflow.
- Record
CVE-2002-1401- CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Buffer overflows in (1) circle_poly, (2) path_encode and (3) path_add (also incorrectly identified as path_addr) for PostgreSQL 7.2.3 and earlier allow attackers to cause a denial of service and possibly execute arbitrary code, possibly as a result of an integer overflow.
- Record
CVE-2002-1401- Updated
- 2026-11-02
EUVDEUVD-2002-1384 No score
Buffer overflows in (1) circle_poly, (2) path_encode and (3) path_add (also incorrectly identified as path_addr) for PostgreSQL 7.2.3 and earlier allow attackers to cause a denial of service and possibly execute arbitrary code, possibly as a result of an integer overflow.
- Record
EUVD-2002-1384- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xcqr-pm35-6p88 No score
Buffer overflows in (1) circle_poly, (2) path_encode and (3) path_add (also incorrectly...
Buffer overflows in (1) circle_poly, (2) path_encode and (3) path_add (also incorrectly identified as path_addr) for PostgreSQL 7.2.3 and earlier allow attackers to cause a denial of service and possibly execute arbitrary code, possibly as a result of an integer overflow.
- Record
GHSA-xcqr-pm35-6p88- Weakness
- CWE-119
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
postgresqlDebian:3.0 |
before 7.2.1-2woody2 | 7.2.1-2woody2 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
distro.conectiva.com.br/atualizacoes?id=a&anuncio=000524
archives.postgresql.org/pgsql-hackers/2002-08/msg02047.php
secunia.com/advisories/8034
archives.postgresql.org/pgsql-hackers/2002-08/msg02081.php
redhat.com/support/errata/RHSA-2003-001.html
debian.org/security/2002/dsa-165
nvd.nist.gov/vuln/detail/CVE-2002-1401
github.com/advisories/GHSA-xcqr-pm35-6p88