Every CVE Search/ Get API key

CVE-2003-0901

Buffer overflow in to_ascii for PostgreSQL 7.2.x, and 7.3.x before 7.3.4, allows remote attackers...

7.5 HighFix available

Buffer overflow in to_ascii for PostgreSQL 7.2.x, and 7.3.x before 7.3.4, allows remote attackers to execute arbitrary code.

Exploit likelihood

4.75%Down 3.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Buffer overflow in to_ascii for PostgreSQL 7.2.x, and 7.3.x before 7.3.4, allows remote attackers to execute arbitrary code.

Record
CVE-2003-0901
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Buffer overflow in to_ascii for PostgreSQL 7.2.x, and 7.3.x before 7.3.4, allows remote attackers to execute arbitrary code.

Record
CVE-2003-0901
Updated
2026-11-02
EUVDEUVD-2003-0891 No score

Buffer overflow in to_ascii for PostgreSQL 7.2.x, and 7.3.x before 7.3.4, allows remote attackers to execute arbitrary code.

Record
EUVD-2003-0891
Updated
2026-11-03
GitHub AdvisoriesGHSA-8584-8hj6-m5v3 No score

Buffer overflow in to_ascii for PostgreSQL 7.2.x, and 7.3.x before 7.3.4, allows remote attackers...

Buffer overflow in to_ascii for PostgreSQL 7.2.x, and 7.3.x before 7.3.4, allows remote attackers to execute arbitrary code.

Record
GHSA-8584-8hj6-m5v3
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
postgresql
Debian:3.0
before 7.2.1-2woody4
7.2.1-2woody4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2003-0901 is a high vulnerability (CVSS 7.5) in Postgresql, published October 30, 2003. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.75%, the 91st percentile. Fixed in postgresql 7.2.1-2woody4.

References

MoveEnter Open