CVE-2004-0256
GNU libtool before 1.5.2, during compile time, allows local users to overwrite arbitrary files...
GNU libtool before 1.5.2, during compile time, allows local users to overwrite arbitrary files via a symlink attack on libtool directories in /tmp.
Exploit likelihood
What each source reports
NVD Score used
2.1
GNU libtool before 1.5.2, during compile time, allows local users to overwrite arbitrary files via a symlink attack on libtool directories in /tmp.
- Record
CVE-2004-0256- CVSS 2.0
- 2.1 Low
AV:L/AC:L/Au:N/C:N/I:P/A:N - Updated
- 2026-11-02
CVE List No score
GNU libtool before 1.5.2, during compile time, allows local users to overwrite arbitrary files via a symlink attack on libtool directories in /tmp.
- Record
CVE-2004-0256- Updated
- 2026-11-02
EUVDEUVD-2004-0256 No score
GNU libtool before 1.5.2, during compile time, allows local users to overwrite arbitrary files via a symlink attack on libtool directories in /tmp.
- Record
EUVD-2004-0256- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-v7hr-fgm3-v42f No score
GNU libtool before 1.5.2, during compile time, allows local users to overwrite arbitrary files...
GNU libtool before 1.5.2, during compile time, allows local users to overwrite arbitrary files via a symlink attack on libtool directories in /tmp.
- Record
GHSA-v7hr-fgm3-v42f- Updated
- 2026-11-02
OSV No score
GNU libtool before 1.5.2, during compile time, allows local users to overwrite arbitrary files via a symlink attack on libtool directories in /tmp.
- Record
CVE-2004-0256- Updated
- 2026-11-02
OSVDEBIAN-CVE-2004-0256 No score
GNU libtool before 1.5.2, during compile time, allows local users to overwrite arbitrary files via a symlink attack on libtool directories in /tmp.
- Record
DEBIAN-CVE-2004-0256- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2004-0256 is a low vulnerability (CVSS 2.1) in Gnu Libtool, published September 1, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.35%, the 28th percentile. Fixed in libtool 1.5.6.