Every CVE Search/ Get API key

CVE-2004-0402

Buffer overflow in xpcd-svga in xpcd before 2.08, and possibly other versions, may allow local...

4.6 MediumFix available

Buffer overflow in xpcd-svga in xpcd before 2.08, and possibly other versions, may allow local users to execute arbitrary code.

Exploit likelihood

0.48%Down 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.6

Buffer overflow in xpcd-svga in xpcd before 2.08, and possibly other versions, may allow local users to execute arbitrary code.

Record
CVE-2004-0402
CVSS 2.0
4.6 MediumAV:L/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Buffer overflow in xpcd-svga in xpcd before 2.08, and possibly other versions, may allow local users to execute arbitrary code.

Record
CVE-2004-0402
Updated
2026-11-02
EUVDEUVD-2004-0402 No score

Buffer overflow in xpcd-svga in xpcd before 2.08, and possibly other versions, may allow local users to execute arbitrary code.

Record
EUVD-2004-0402
Updated
2026-11-03
GitHub AdvisoriesGHSA-fh9x-3h5x-gmx4 No score

Buffer overflow in xpcd-svga in xpcd before 2.08, and possibly other versions, may allow local...

Buffer overflow in xpcd-svga in xpcd before 2.08, and possibly other versions, may allow local users to execute arbitrary code.

Record
GHSA-fh9x-3h5x-gmx4
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xpcd
Debian:3.0
before 2.08-8woody2
2.08-8woody2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0402 is a medium vulnerability (CVSS 4.6) in Xpcd, published May 22, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.48%, the 41st percentile. Fixed in xpcd 2.08-8woody2.

References

MoveEnter Open