Every CVE Search/ Get API key

CVE-2004-0454

Buffer overflow in the msg function for rlpr daemon (rlprd) 2.04 allows local users to execute...

7.2 HighFix available

Buffer overflow in the msg function for rlpr daemon (rlprd) 2.04 allows local users to execute arbitrary code.

Exploit likelihood

0.68%Down 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.2

Buffer overflow in the msg function for rlpr daemon (rlprd) 2.04 allows local users to execute arbitrary code.

Record
CVE-2004-0454
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

Buffer overflow in the msg function for rlpr daemon (rlprd) 2.04 allows local users to execute arbitrary code.

Record
CVE-2004-0454
Updated
2026-11-02
EUVDEUVD-2004-0453 No score

Buffer overflow in the msg function for rlpr daemon (rlprd) 2.04 allows local users to execute arbitrary code.

Record
EUVD-2004-0453
Updated
2026-11-03
GitHub AdvisoriesGHSA-pjrr-69h2-f25x No score

Buffer overflow in the msg function for rlpr daemon (rlprd) 2.04 allows local users to execute...

Buffer overflow in the msg function for rlpr daemon (rlprd) 2.04 allows local users to execute arbitrary code.

Record
GHSA-pjrr-69h2-f25x
Updated
2026-11-02
OSV No score

Buffer overflow in the msg function for rlpr daemon (rlprd) 2.04 allows local users to execute arbitrary code.

Record
CVE-2004-0454
Updated
2026-11-02
OSVDEBIAN-CVE-2004-0454 No score

Buffer overflow in the msg function for rlpr daemon (rlprd) 2.04 allows local users to execute arbitrary code.

Record
DEBIAN-CVE-2004-0454
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
rlpr
Debian:12
before 2.02-7.1
2.02-7.1
rlpr
Debian:13
before 2.02-7.1
2.02-7.1
rlpr
Debian:14
before 2.02-7.1
2.02-7.1
rlpr
Debian:3.0
From an advisory covering 2 CVEs
before 2.02-7woody1
2.02-7woody1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0454 is a high vulnerability (CVSS 7.2) in Rlpr, published June 19, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.68%, the 52nd percentile. Fixed in rlpr 2.02-7.1.

References

MoveEnter Open