Every CVE Search/ Get API key

CVE-2004-0600

Buffer overflow in the Samba Web Administration Tool (SWAT) in Samba 3.0.2 to 3.0.4 allows remote...

10.0 HighPublic exploitFix available

Buffer overflow in the Samba Web Administration Tool (SWAT) in Samba 3.0.2 to 3.0.4 allows remote attackers to execute arbitrary code via an invalid base-64 character during HTTP basic authentication.

Exploit likelihood

29.4%Down 25.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

Buffer overflow in the Samba Web Administration Tool (SWAT) in Samba 3.0.2 to 3.0.4 allows remote attackers to execute arbitrary code via an invalid base-64 character during HTTP basic authentication.

Record
CVE-2004-0600
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

Buffer overflow in the Samba Web Administration Tool (SWAT) in Samba 3.0.2 to 3.0.4 allows remote attackers to execute arbitrary code via an invalid base-64 character during HTTP basic authentication.

Record
CVE-2004-0600
Updated
2026-11-02
EUVDEUVD-2004-0599 No score

Buffer overflow in the Samba Web Administration Tool (SWAT) in Samba 3.0.2 to 3.0.4 allows remote attackers to execute arbitrary code via an invalid base-64 character during HTTP basic authentication.

Record
EUVD-2004-0599
Updated
2026-11-03
GitHub AdvisoriesGHSA-6wf7-h6x3-vqqj No score

Buffer overflow in the Samba Web Administration Tool (SWAT) in Samba 3.0.2 to 3.0.4 allows remote...

Buffer overflow in the Samba Web Administration Tool (SWAT) in Samba 3.0.2 to 3.0.4 allows remote attackers to execute arbitrary code via an invalid base-64 character during HTTP basic authentication.

Record
GHSA-6wf7-h6x3-vqqj
Updated
2026-11-02
OSV No score

Buffer overflow in the Samba Web Administration Tool (SWAT) in Samba 3.0.2 to 3.0.4 allows remote attackers to execute arbitrary code via an invalid base-64 character during HTTP basic authentication.

Record
CVE-2004-0600
Updated
2026-11-02
OSVDEBIAN-CVE-2004-0600 No score

Buffer overflow in the Samba Web Administration Tool (SWAT) in Samba 3.0.2 to 3.0.4 allows remote attackers to execute arbitrary code via an invalid base-64 character during HTTP basic authentication.

Record
DEBIAN-CVE-2004-0600
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
samba
Debian:12
before 3.0.5
3.0.5
samba
Debian:13
before 3.0.5
3.0.5
samba
Debian:14
before 3.0.5
3.0.5
samba
Red Hat:enterprise_linux:3::as
before 0:3.0.4-6.3E
0:3.0.4-6.3E
samba-client
Red Hat:enterprise_linux:3::as
before 0:3.0.4-6.3E
0:3.0.4-6.3E
samba-common
Red Hat:enterprise_linux:3::as
before 0:3.0.4-6.3E
0:3.0.4-6.3E
samba-swat
Red Hat:enterprise_linux:3::as
before 0:3.0.4-6.3E
0:3.0.4-6.3E
samba
Red Hat:enterprise_linux:3::desktop
before 0:3.0.4-6.3E
0:3.0.4-6.3E
samba-client
Red Hat:enterprise_linux:3::desktop
before 0:3.0.4-6.3E
0:3.0.4-6.3E
samba-common
Red Hat:enterprise_linux:3::desktop
before 0:3.0.4-6.3E
0:3.0.4-6.3E
Show 9 moreShow less
Affected packages
PackageAffectedFixed
samba-swat
Red Hat:enterprise_linux:3::desktop
before 0:3.0.4-6.3E
0:3.0.4-6.3E
samba
Red Hat:enterprise_linux:3::es
before 0:3.0.4-6.3E
0:3.0.4-6.3E
samba-client
Red Hat:enterprise_linux:3::es
before 0:3.0.4-6.3E
0:3.0.4-6.3E
samba-common
Red Hat:enterprise_linux:3::es
before 0:3.0.4-6.3E
0:3.0.4-6.3E
samba-swat
Red Hat:enterprise_linux:3::es
before 0:3.0.4-6.3E
0:3.0.4-6.3E
samba
Red Hat:enterprise_linux:3::ws
before 0:3.0.4-6.3E
0:3.0.4-6.3E
samba-client
Red Hat:enterprise_linux:3::ws
before 0:3.0.4-6.3E
0:3.0.4-6.3E
samba-common
Red Hat:enterprise_linux:3::ws
before 0:3.0.4-6.3E
0:3.0.4-6.3E
samba-swat
Red Hat:enterprise_linux:3::ws
before 0:3.0.4-6.3E
0:3.0.4-6.3E

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBSamba 3.0.4 - SWAT Authorisation Buffer Overflow2004-07-22

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0600 is a high vulnerability (CVSS 10.0) in Samba, published July 23, 2004. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 29.4%, the 98th percentile. Fixed in samba 3.0.5.

References

Show 34 moreShow less
MoveEnter Open