Every CVE Search/ Get API key

CVE-2004-0601

distcc before 2.16, when running on 64-bit platforms, does not interpret IP-based access control...

7.5 HighFix available

distcc before 2.16, when running on 64-bit platforms, does not interpret IP-based access control rules correctly, which could allow remote attackers to bypass intended restrictions.

Exploit likelihood

1.58%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

distcc before 2.16, when running on 64-bit platforms, does not interpret IP-based access control rules correctly, which could allow remote attackers to bypass intended restrictions.

Record
CVE-2004-0601
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

distcc before 2.16, when running on 64-bit platforms, does not interpret IP-based access control rules correctly, which could allow remote attackers to bypass intended restrictions.

Record
CVE-2004-0601
Updated
2026-11-02
EUVDEUVD-2004-0600 No score

distcc before 2.16, when running on 64-bit platforms, does not interpret IP-based access control rules correctly, which could allow remote attackers to bypass intended restrictions.

Record
EUVD-2004-0600
Updated
2026-11-03
GitHub AdvisoriesGHSA-vxrm-mh87-53gf No score

distcc before 2.16, when running on 64-bit platforms, does not interpret IP-based access control...

distcc before 2.16, when running on 64-bit platforms, does not interpret IP-based access control rules correctly, which could allow remote attackers to bypass intended restrictions.

Record
GHSA-vxrm-mh87-53gf
Updated
2026-11-02
OSV No score

distcc before 2.16, when running on 64-bit platforms, does not interpret IP-based access control rules correctly, which could allow remote attackers to bypass intended restrictions.

Record
CVE-2004-0601
Updated
2026-11-02
OSVDEBIAN-CVE-2004-0601 No score

distcc before 2.16, when running on 64-bit platforms, does not interpret IP-based access control rules correctly, which could allow remote attackers to bypass intended restrictions.

Record
DEBIAN-CVE-2004-0601
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
distcc
Debian:12
before 2.18.1-4
2.18.1-4
distcc
Debian:13
before 2.18.1-4
2.18.1-4
distcc
Debian:14
before 2.18.1-4
2.18.1-4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0601 is a high vulnerability (CVSS 7.5) in Distcc, published November 19, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.58%, the 75th percentile. Fixed in distcc 2.18.1-4.

References

MoveEnter Open