Every CVE Search/ Get API key

CVE-2004-0694

Buffer overflow in LHA 1.14 and earlier allows remote attackers to cause a denial of service ...

6.8 MediumFix available

CVE-2004-0694 is a medium vulnerability (CVSS 6.8) in Tsugio Okamoto Lha, published February 4, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.55%, the 85th percentile. Fixed in lha 0:1.14i-10.4.

Buffer overflow in LHA 1.14 and earlier allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors related to "command line processing," a different vulnerability than CVE-2004-0771. NOTE: this issue may be REJECTED if there are not any cases in which LHA is setuid or is otherwise used across security boundaries.

Exploit likelihood

2.55%Down 1.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Buffer overflow in LHA 1.14 and earlier allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors related to "command line processing," a different vulnerability than CVE-2004-0771. NOTE: this issue may be REJECTED if there are not any cases in which LHA is setuid or is otherwise used across security boundaries.

Record
CVE-2004-0694
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in LHA 1.14 and earlier allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors related to "command line processing," a different vulnerability than CVE-2004-0771. NOTE: this issue may be REJECTED if there are not any cases in which LHA is setuid or is otherwise used across security boundaries.

Record
CVE-2004-0694
Updated
2026-11-02
EUVDEUVD-2004-0693 No score

Buffer overflow in LHA 1.14 and earlier allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors related to "command line processing," a different vulnerability than CVE-2004-0771. NOTE: this issue may be REJECTED if there are not any cases in which LHA is setuid or is otherwise used across security boundaries.

Record
EUVD-2004-0693
Updated
2026-11-03
GitHub AdvisoriesGHSA-6446-v6gj-7jm6 No score

Buffer overflow in LHA 1.14 and earlier allows remote attackers to cause a denial of service ...

Buffer overflow in LHA 1.14 and earlier allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors related to "command line processing," a different vulnerability than CVE-2004-0771. NOTE: this issue may be REJECTED if there are not any cases in which LHA is setuid or is otherwise used across security boundaries.

Record
GHSA-6446-v6gj-7jm6
Weakness
CWE-119
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lha
Red Hat:enterprise_linux:3::as
before 0:1.14i-10.4
0:1.14i-10.4
lha-debuginfo
Red Hat:enterprise_linux:3::as
before 0:1.14i-10.4
0:1.14i-10.4
lha
Red Hat:enterprise_linux:3::desktop
before 0:1.14i-10.4
0:1.14i-10.4
lha-debuginfo
Red Hat:enterprise_linux:3::desktop
before 0:1.14i-10.4
0:1.14i-10.4
lha
Red Hat:enterprise_linux:3::es
before 0:1.14i-10.4
0:1.14i-10.4
lha-debuginfo
Red Hat:enterprise_linux:3::es
before 0:1.14i-10.4
0:1.14i-10.4
lha
Red Hat:enterprise_linux:3::ws
before 0:1.14i-10.4
0:1.14i-10.4
lha-debuginfo
Red Hat:enterprise_linux:3::ws
before 0:1.14i-10.4
0:1.14i-10.4

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 20 moreShow less
MoveEnter Open