Every CVE Search/ Get API key

CVE-2004-0967

The (1) pj-gs.sh, (2) ps2epsi, (3) pv.sh, and (4) sysvlp.sh scripts in the ESP Ghostscript (espgs...

7.2 HighFix available

The (1) pj-gs.sh, (2) ps2epsi, (3) pv.sh, and (4) sysvlp.sh scripts in the ESP Ghostscript (espgs) package in Trustix Secure Linux 1.5 through 2.1, and other operating systems, allow local users to overwrite files via a symlink attack on temporary files.

Exploit likelihood

0.47%Down 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.2

The (1) pj-gs.sh, (2) ps2epsi, (3) pv.sh, and (4) sysvlp.sh scripts in the ESP Ghostscript (espgs) package in Trustix Secure Linux 1.5 through 2.1, and other operating systems, allow local users to overwrite files via a symlink attack on temporary files.

Record
CVE-2004-0967
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-59
Updated
2026-11-02
CVE List No score

The (1) pj-gs.sh, (2) ps2epsi, (3) pv.sh, and (4) sysvlp.sh scripts in the ESP Ghostscript (espgs) package in Trustix Secure Linux 1.5 through 2.1, and other operating systems, allow local users to overwrite files via a symlink attack on temporary files.

Record
CVE-2004-0967
Updated
2026-11-02
EUVDEUVD-2004-0965 No score

The (1) pj-gs.sh, (2) ps2epsi, (3) pv.sh, and (4) sysvlp.sh scripts in the ESP Ghostscript (espgs) package in Trustix Secure Linux 1.5 through 2.1, and other operating systems, allow local users to overwrite files via a symlink attack on temporary files.

Record
EUVD-2004-0965
Updated
2026-11-03
GitHub AdvisoriesGHSA-jp9f-f85w-rv5v No score

The (1) pj-gs.sh, (2) ps2epsi, (3) pv.sh, and (4) sysvlp.sh scripts in the ESP Ghostscript (espgs...

The (1) pj-gs.sh, (2) ps2epsi, (3) pv.sh, and (4) sysvlp.sh scripts in the ESP Ghostscript (espgs) package in Trustix Secure Linux 1.5 through 2.1, and other operating systems, allow local users to overwrite files via a symlink attack on temporary files.

Record
GHSA-jp9f-f85w-rv5v
Weakness
CWE-59
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ghostscript
Red Hat:enterprise_linux:3::as
before 0:7.05-32.1.10
0:7.05-32.1.10
ghostscript-debuginfo
Red Hat:enterprise_linux:3::as
before 0:7.05-32.1.10
0:7.05-32.1.10
ghostscript-devel
Red Hat:enterprise_linux:3::as
before 0:7.05-32.1.10
0:7.05-32.1.10
hpijs
Red Hat:enterprise_linux:3::as
before 0:1.3-32.1.10
0:1.3-32.1.10
ghostscript
Red Hat:enterprise_linux:3::desktop
before 0:7.05-32.1.10
0:7.05-32.1.10
ghostscript-debuginfo
Red Hat:enterprise_linux:3::desktop
before 0:7.05-32.1.10
0:7.05-32.1.10
ghostscript-devel
Red Hat:enterprise_linux:3::desktop
before 0:7.05-32.1.10
0:7.05-32.1.10
hpijs
Red Hat:enterprise_linux:3::desktop
before 0:1.3-32.1.10
0:1.3-32.1.10
ghostscript
Red Hat:enterprise_linux:3::es
before 0:7.05-32.1.10
0:7.05-32.1.10
ghostscript-debuginfo
Red Hat:enterprise_linux:3::es
before 0:7.05-32.1.10
0:7.05-32.1.10
Show 6 moreShow less
Affected packages
PackageAffectedFixed
ghostscript-devel
Red Hat:enterprise_linux:3::es
before 0:7.05-32.1.10
0:7.05-32.1.10
hpijs
Red Hat:enterprise_linux:3::es
before 0:1.3-32.1.10
0:1.3-32.1.10
ghostscript
Red Hat:enterprise_linux:3::ws
before 0:7.05-32.1.10
0:7.05-32.1.10
ghostscript-debuginfo
Red Hat:enterprise_linux:3::ws
before 0:7.05-32.1.10
0:7.05-32.1.10
ghostscript-devel
Red Hat:enterprise_linux:3::ws
before 0:7.05-32.1.10
0:7.05-32.1.10
hpijs
Red Hat:enterprise_linux:3::ws
before 0:1.3-32.1.10
0:1.3-32.1.10

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0967 is a high vulnerability (CVSS 7.2) in Aladdin Enterprises Ghostscript, published October 20, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.47%, the 41st percentile. Fixed in ghostscript 0:7.05-32.1.10.

References

Show 14 moreShow less
MoveEnter Open