CVE-2004-1106
Cross-site scripting (XSS) vulnerability in Gallery 1.4.4-pl3 and earlier allows remote attackers...
Cross-site scripting (XSS) vulnerability in Gallery 1.4.4-pl3 and earlier allows remote attackers to execute arbitrary web script or HTML via "specially formed URLs," possibly via the include parameter in index.php.
Exploit likelihood
What each source reports
NVD Score used
6.8
Cross-site scripting (XSS) vulnerability in Gallery 1.4.4-pl3 and earlier allows remote attackers to execute arbitrary web script or HTML via "specially formed URLs," possibly via the include parameter in index.php.
- Record
CVE-2004-1106- CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in Gallery 1.4.4-pl3 and earlier allows remote attackers to execute arbitrary web script or HTML via "specially formed URLs," possibly via the include parameter in index.php.
- Record
CVE-2004-1106- Updated
- 2026-11-02
EUVDEUVD-2004-1104 No score
Cross-site scripting (XSS) vulnerability in Gallery 1.4.4-pl3 and earlier allows remote attackers to execute arbitrary web script or HTML via "specially formed URLs," possibly via the include parameter in index.php.
- Record
EUVD-2004-1104- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6mqx-3r5h-wq66 No score
Cross-site scripting (XSS) vulnerability in Gallery 1.4.4-pl3 and earlier allows remote attackers...
Cross-site scripting (XSS) vulnerability in Gallery 1.4.4-pl3 and earlier allows remote attackers to execute arbitrary web script or HTML via "specially formed URLs," possibly via the include parameter in index.php.
- Record
GHSA-6mqx-3r5h-wq66- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
galleryDebian:3.0 |
before 1.2.5-8woody3, plus listed versions 1.2.5-8woody2 |
1.2.5-8woody3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2004-1106 is a medium vulnerability (CVSS 6.8) in Gallery Project Gallery, published December 1, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.48%, the 73rd percentile. Fixed in gallery 1.2.5-8woody3.
References
exchange.xforce.ibmcloud.com/vulnerabilities/17948
securityfocus.com/bid/11602
debian.org/security/2005/dsa-642
gentoo.org/security/en/glsa/glsa-200411-10.xml
gallery.menalto.com/modules.php?op=modload&name=News&file=article&sid=142&mode=thread&order=0&thold=0
g3cko.info/gallery2-4.patch
nvd.nist.gov/vuln/detail/CVE-2004-1106
github.com/advisories/GHSA-6mqx-3r5h-wq66