Every CVE Search/ Get API key

CVE-2004-1185

Enscript 1.6.3 does not sanitize filenames, which allows remote attackers or local users to...

7.5 HighFix available

Enscript 1.6.3 does not sanitize filenames, which allows remote attackers or local users to execute arbitrary commands via crafted filenames.

Exploit likelihood

4.44%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Enscript 1.6.3 does not sanitize filenames, which allows remote attackers or local users to execute arbitrary commands via crafted filenames.

Record
CVE-2004-1185
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Enscript 1.6.3 does not sanitize filenames, which allows remote attackers or local users to execute arbitrary commands via crafted filenames.

Record
CVE-2004-1185
Updated
2026-11-02
EUVDEUVD-2004-1182 No score

Enscript 1.6.3 does not sanitize filenames, which allows remote attackers or local users to execute arbitrary commands via crafted filenames.

Record
EUVD-2004-1182
Updated
2026-11-03
GitHub AdvisoriesGHSA-8xcw-4f7q-cw3g No score

Enscript 1.6.3 does not sanitize filenames, which allows remote attackers or local users to...

Enscript 1.6.3 does not sanitize filenames, which allows remote attackers or local users to execute arbitrary commands via crafted filenames.

Record
GHSA-8xcw-4f7q-cw3g
Updated
2026-11-02
OSV No score

Enscript 1.6.3 does not sanitize filenames, which allows remote attackers or local users to execute arbitrary commands via crafted filenames.

Record
CVE-2004-1185
Updated
2026-11-02
OSVDEBIAN-CVE-2004-1185 No score

Enscript 1.6.3 does not sanitize filenames, which allows remote attackers or local users to execute arbitrary commands via crafted filenames.

Record
DEBIAN-CVE-2004-1185
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
enscript
Debian:12
before 1.6.4-6
1.6.4-6
enscript
Debian:13
before 1.6.4-6
1.6.4-6
enscript
Debian:14
before 1.6.4-6
1.6.4-6
enscript
Debian:3.0
From an advisory covering 3 CVEs
before 1.6.3-1.3, plus listed versions
1.6.3-1.1
1.6.3-1.3
enscript
Red Hat:enterprise_linux:3::as
From an advisory covering 3 CVEs
before 0:1.6.1-24.4
0:1.6.1-24.4
enscript-debuginfo
Red Hat:enterprise_linux:3::as
From an advisory covering 3 CVEs
before 0:1.6.1-24.4
0:1.6.1-24.4
enscript
Red Hat:enterprise_linux:3::desktop
From an advisory covering 3 CVEs
before 0:1.6.1-24.4
0:1.6.1-24.4
enscript-debuginfo
Red Hat:enterprise_linux:3::desktop
From an advisory covering 3 CVEs
before 0:1.6.1-24.4
0:1.6.1-24.4
enscript
Red Hat:enterprise_linux:3::es
From an advisory covering 3 CVEs
before 0:1.6.1-24.4
0:1.6.1-24.4
enscript-debuginfo
Red Hat:enterprise_linux:3::es
From an advisory covering 3 CVEs
before 0:1.6.1-24.4
0:1.6.1-24.4
Show 10 moreShow less
Affected packages
PackageAffectedFixed
enscript
Red Hat:enterprise_linux:3::ws
From an advisory covering 3 CVEs
before 0:1.6.1-24.4
0:1.6.1-24.4
enscript-debuginfo
Red Hat:enterprise_linux:3::ws
From an advisory covering 3 CVEs
before 0:1.6.1-24.4
0:1.6.1-24.4
enscript
Red Hat:enterprise_linux:4::as
From an advisory covering 3 CVEs
before 0:1.6.1-28.3
0:1.6.1-28.3
enscript-debuginfo
Red Hat:enterprise_linux:4::as
From an advisory covering 3 CVEs
before 0:1.6.1-28.3
0:1.6.1-28.3
enscript
Red Hat:enterprise_linux:4::desktop
From an advisory covering 3 CVEs
before 0:1.6.1-28.3
0:1.6.1-28.3
enscript-debuginfo
Red Hat:enterprise_linux:4::desktop
From an advisory covering 3 CVEs
before 0:1.6.1-28.3
0:1.6.1-28.3
enscript
Red Hat:enterprise_linux:4::es
From an advisory covering 3 CVEs
before 0:1.6.1-28.3
0:1.6.1-28.3
enscript-debuginfo
Red Hat:enterprise_linux:4::es
From an advisory covering 3 CVEs
before 0:1.6.1-28.3
0:1.6.1-28.3
enscript
Red Hat:enterprise_linux:4::ws
From an advisory covering 3 CVEs
before 0:1.6.1-28.3
0:1.6.1-28.3
enscript-debuginfo
Red Hat:enterprise_linux:4::ws
From an advisory covering 3 CVEs
before 0:1.6.1-28.3
0:1.6.1-28.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-1185 is a high vulnerability (CVSS 7.5) in Gnu Enscript, published January 21, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.44%, the 91st percentile. Fixed in enscript 1.6.4-6.

References

Show 31 moreShow less
MoveEnter Open