CVE-2004-1343
CVS 1.12 and earlier on Debian GNU/Linux does not properly handle when a mapping for the current...
CVS 1.12 and earlier on Debian GNU/Linux does not properly handle when a mapping for the current repository does not exist in the cvs-repouids file, which allows remote attackers to cause a denial of service (server crash).
Exploit likelihood
What each source reports
NVD Score used
5.0
CVS 1.12 and earlier on Debian GNU/Linux does not properly handle when a mapping for the current repository does not exist in the cvs-repouids file, which allows remote attackers to cause a denial of service (server crash).
- Record
CVE-2004-1343- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Updated
- 2026-11-02
CVE List No score
CVS 1.12 and earlier on Debian GNU/Linux does not properly handle when a mapping for the current repository does not exist in the cvs-repouids file, which allows remote attackers to cause a denial of service (server crash).
- Record
CVE-2004-1343- Updated
- 2026-11-02
EUVDEUVD-2004-1340 No score
CVS 1.12 and earlier on Debian GNU/Linux does not properly handle when a mapping for the current repository does not exist in the cvs-repouids file, which allows remote attackers to cause a denial of service (server crash).
- Record
EUVD-2004-1340- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g6wg-3fff-rr58 No score
CVS 1.12 and earlier on Debian GNU/Linux does not properly handle when a mapping for the current...
CVS 1.12 and earlier on Debian GNU/Linux does not properly handle when a mapping for the current repository does not exist in the cvs-repouids file, which allows remote attackers to cause a denial of service (server crash).
- Record
GHSA-g6wg-3fff-rr58- Updated
- 2026-11-02
OSV No score
CVS 1.12 and earlier on Debian GNU/Linux does not properly handle when a mapping for the current repository does not exist in the cvs-repouids file, which allows remote attackers to cause a denial of service (server crash).
- Record
CVE-2004-1343- Updated
- 2026-11-02
OSVDEBIAN-CVE-2004-1343 No score
CVS 1.12 and earlier on Debian GNU/Linux does not properly handle when a mapping for the current repository does not exist in the cvs-repouids file, which allows remote attackers to cause a denial of service (server crash).
- Record
DEBIAN-CVE-2004-1343- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cvsDebian:12 |
before 1:1.12.9-12 | 1:1.12.9-12 |
cvsDebian:13 |
before 1:1.12.9-12 | 1:1.12.9-12 |
cvsDebian:14 |
before 1:1.12.9-12 | 1:1.12.9-12 |
cvsDebian:3.0 From an advisory covering 2 CVEs |
before 1.11.1p1debian-10, plus listed versions 1.11.1p1debian-9woody7 |
1.11.1p1debian-10 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2004-1343 is a medium vulnerability (CVSS 5.0) in Cvs, published December 31, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.93%, the 80th percentile. Fixed in cvs 1:1.12.9-12.