Every CVE Search/ Get API key

CVE-2004-1440

Multiple heap-based buffer overflows in the modpow function in PuTTY before 0.55 allow (1) remote...

7.5 HighFix available

Multiple heap-based buffer overflows in the modpow function in PuTTY before 0.55 allow (1) remote attackers to execute arbitrary code via an SSH2 packet with a base argument that is larger than the mod argument, which causes the modpow function to write memory before the beginning of its buffer, and (2) remote malicious servers to cause a denial of service (client crash) and possibly execute arbitrary code via a large bignum during authentication.

Exploit likelihood

4.11%Down 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Multiple heap-based buffer overflows in the modpow function in PuTTY before 0.55 allow (1) remote attackers to execute arbitrary code via an SSH2 packet with a base argument that is larger than the mod argument, which causes the modpow function to write memory before the beginning of its buffer, and (2) remote malicious servers to cause a denial of service (client crash) and possibly execute arbitrary code via a large bignum during authentication.

Record
CVE-2004-1440
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Multiple heap-based buffer overflows in the modpow function in PuTTY before 0.55 allow (1) remote attackers to execute arbitrary code via an SSH2 packet with a base argument that is larger than the mod argument, which causes the modpow function to write memory before the beginning of its buffer, and (2) remote malicious servers to cause a denial of service (client crash) and possibly execute arbitrary code via a large bignum during authentication.

Record
CVE-2004-1440
Updated
2026-11-02
EUVDEUVD-2004-1437 No score

Multiple heap-based buffer overflows in the modpow function in PuTTY before 0.55 allow (1) remote attackers to execute arbitrary code via an SSH2 packet with a base argument that is larger than the mod argument, which causes the modpow function to write memory before the beginning of its buffer, and (2) remote malicious servers to cause a denial of service (client crash) and possibly execute arbitrary code via a large bignum during authentication.

Record
EUVD-2004-1437
Updated
2026-11-03
GitHub AdvisoriesGHSA-8hpx-pjhm-89hr No score

Multiple heap-based buffer overflows in the modpow function in PuTTY before 0.55 allow (1) remote...

Multiple heap-based buffer overflows in the modpow function in PuTTY before 0.55 allow (1) remote attackers to execute arbitrary code via an SSH2 packet with a base argument that is larger than the mod argument, which causes the modpow function to write memory before the beginning of its buffer, and (2) remote malicious servers to cause a denial of service (client crash) and possibly execute arbitrary code via a large bignum during authentication.

Record
GHSA-8hpx-pjhm-89hr
Updated
2026-11-02
OSV No score

Multiple heap-based buffer overflows in the modpow function in PuTTY before 0.55 allow (1) remote attackers to execute arbitrary code via an SSH2 packet with a base argument that is larger than the mod argument, which causes the modpow function to write memory before the beginning of its buffer, and (2) remote malicious servers to cause a denial of service (client crash) and possibly execute arbitrary code via a large bignum during authentication.

Record
CVE-2004-1440
Updated
2026-11-02
OSVDEBIAN-CVE-2004-1440 No score

Multiple heap-based buffer overflows in the modpow function in PuTTY before 0.55 allow (1) remote attackers to execute arbitrary code via an SSH2 packet with a base argument that is larger than the mod argument, which causes the modpow function to write memory before the beginning of its buffer, and (2) remote malicious servers to cause a denial of service (client crash) and possibly execute arbitrary code via a large bignum during authentication.

Record
DEBIAN-CVE-2004-1440
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
putty
Debian:12
before 0.56-1
0.56-1
putty
Debian:13
before 0.56-1
0.56-1
putty
Debian:14
before 0.56-1
0.56-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-1440 is a high vulnerability (CVSS 7.5) in Putty, published December 31, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.11%, the 90th percentile. Fixed in putty 0.56-1.

References

Show 4 moreShow less
MoveEnter Open