Every CVE Search/ Get API key

CVE-2005-1524

PHP file inclusion vulnerability in top_graph_header.php in Cacti 0.8.6d and possibly earlier...

5.0 MediumPublic exploitFix available

PHP file inclusion vulnerability in top_graph_header.php in Cacti 0.8.6d and possibly earlier versions allows remote attackers to execute arbitrary PHP code via the config[library_path] parameter.

Exploit likelihood

15.9%Up 3.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

PHP file inclusion vulnerability in top_graph_header.php in Cacti 0.8.6d and possibly earlier versions allows remote attackers to execute arbitrary PHP code via the config[library_path] parameter.

Record
CVE-2005-1524
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

PHP file inclusion vulnerability in top_graph_header.php in Cacti 0.8.6d and possibly earlier versions allows remote attackers to execute arbitrary PHP code via the config[library_path] parameter.

Record
CVE-2005-1524
Updated
2026-11-02
EUVDEUVD-2005-1527 No score

PHP file inclusion vulnerability in top_graph_header.php in Cacti 0.8.6d and possibly earlier versions allows remote attackers to execute arbitrary PHP code via the config[library_path] parameter.

Record
EUVD-2005-1527
Updated
2026-11-03
GitHub AdvisoriesGHSA-x9gq-h28h-fhwf No score

PHP file inclusion vulnerability in top_graph_header.php in Cacti 0.8.6d and possibly earlier...

PHP file inclusion vulnerability in top_graph_header.php in Cacti 0.8.6d and possibly earlier versions allows remote attackers to execute arbitrary PHP code via the config[library_path] parameter.

Record
GHSA-x9gq-h28h-fhwf
Updated
2026-11-02
OSV No score

PHP file inclusion vulnerability in top_graph_header.php in Cacti 0.8.6d and possibly earlier versions allows remote attackers to execute arbitrary PHP code via the config[library_path] parameter.

Record
CVE-2005-1524
Updated
2026-11-02
OSVDEBIAN-CVE-2005-1524 No score

PHP file inclusion vulnerability in top_graph_header.php in Cacti 0.8.6d and possibly earlier versions allows remote attackers to execute arbitrary PHP code via the config[library_path] parameter.

Record
DEBIAN-CVE-2005-1524
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cacti
Debian:12
before 0.8.6e-1
0.8.6e-1
cacti
Debian:13
before 0.8.6e-1
0.8.6e-1
cacti
Debian:14
before 0.8.6e-1
0.8.6e-1
cacti
Debian:3.0
From an advisory covering 5 CVEs
before 0.6.7-2.5, plus listed versions
0.6.7-20.6.7-2.10.6.7-2.20.6.7-2.30.6.7-2.4
0.6.7-2.5
cacti
Debian:3.1
From an advisory covering 5 CVEs
before 0.8.6c-7sarge2, plus listed versions
0.8.6c-7
0.8.6c-7sarge2

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-1524 is a medium vulnerability (CVSS 5.0) in The Cacti Group Cacti, published June 22, 2005. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 15.9%, the 96th percentile. Fixed in cacti 0.8.6e-1.

References

Show 8 moreShow less
MoveEnter Open