Every CVE Search/ Get API key

CVE-2005-1545

Integer overflow in the ELF parser in HT Editor before 0.8.0 allows remote attackers to execute...

5.1 MediumFix available

Integer overflow in the ELF parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted ELF file, which leads to a heap-based buffer overflow.

Exploit likelihood

2.21%Down 2.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.1

Integer overflow in the ELF parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted ELF file, which leads to a heap-based buffer overflow.

Record
CVE-2005-1545
CVSS 2.0
5.1 MediumAV:N/AC:H/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Integer overflow in the ELF parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted ELF file, which leads to a heap-based buffer overflow.

Record
CVE-2005-1545
Updated
2026-11-02
EUVDEUVD-2005-1548 No score

Integer overflow in the ELF parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted ELF file, which leads to a heap-based buffer overflow.

Record
EUVD-2005-1548
Updated
2026-11-03
GitHub AdvisoriesGHSA-v5mc-j4jh-5rcf No score

Integer overflow in the ELF parser in HT Editor before 0.8.0 allows remote attackers to execute...

Integer overflow in the ELF parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted ELF file, which leads to a heap-based buffer overflow.

Record
GHSA-v5mc-j4jh-5rcf
Updated
2026-11-02
OSV No score

Integer overflow in the ELF parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted ELF file, which leads to a heap-based buffer overflow.

Record
CVE-2005-1545
Updated
2026-11-02
OSVDEBIAN-CVE-2005-1545 No score

Integer overflow in the ELF parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted ELF file, which leads to a heap-based buffer overflow.

Record
DEBIAN-CVE-2005-1545
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ht
Debian:12
before 0.8.0-3
0.8.0-3
ht
Debian:13
before 0.8.0-3
0.8.0-3
ht
Debian:14
before 0.8.0-3
0.8.0-3
ht
Debian:3.0
before 0.5.0-1woody4, plus listed versions
0.5.0-1
0.5.0-1woody4
ht
Debian:3.1
before 0.8.0-2sarge4, plus listed versions
0.8.0-2
0.8.0-2sarge4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-1545 is a medium vulnerability (CVSS 5.1) in Ht Editor Editor, published May 14, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.21%, the 82nd percentile. Fixed in ht 0.8.0-3.

References

MoveEnter Open