CVE-2005-2869
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4 allow remote...
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4 allow remote attackers to inject arbitrary web script or HTML via (1) the Username to libraries/auth/cookie.auth.lib.php or (2) the error parameter to error.php.
Exploit likelihood
What each source reports
NVD Score used
4.3
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4 allow remote attackers to inject arbitrary web script or HTML via (1) the Username to libraries/auth/cookie.auth.lib.php or (2) the error parameter to error.php.
- Record
CVE-2005-2869- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Updated
- 2026-11-02
CVE List No score
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4 allow remote attackers to inject arbitrary web script or HTML via (1) the Username to libraries/auth/cookie.auth.lib.php or (2) the error parameter to error.php.
- Record
CVE-2005-2869- Updated
- 2026-11-02
EUVDEUVD-2005-2870 No score
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4 allow remote attackers to inject arbitrary web script or HTML via (1) the Username to libraries/auth/cookie.auth.lib.php or (2) the error parameter to error.php.
- Record
EUVD-2005-2870- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f47h-66wf-9744 No score
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4 allow remote...
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4 allow remote attackers to inject arbitrary web script or HTML via (1) the Username to libraries/auth/cookie.auth.lib.php or (2) the error parameter to error.php.
- Record
GHSA-f47h-66wf-9744- Updated
- 2026-11-02
OSV No score
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4 allow remote attackers to inject arbitrary web script or HTML via (1) the Username to libraries/auth/cookie.auth.lib.php or (2) the error parameter to error.php.
- Record
CVE-2005-2869- Updated
- 2026-11-02
OSVDEBIAN-CVE-2005-2869 No score
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4 allow remote attackers to inject arbitrary web script or HTML via (1) the Username to libraries/auth/cookie.auth.lib.php or (2) the error parameter to error.php.
- Record
DEBIAN-CVE-2005-2869- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11171-1 No score
phpMyAdmin-5.1.1-1.2 on GA media
These are all security issues fixed in the phpMyAdmin-5.1.1-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11171-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
phpmyadminDebian:12 |
before 4:2.6.4-pl1-1 | 4:2.6.4-pl1-1 |
phpmyadminDebian:13 |
before 4:2.6.4-pl1-1 | 4:2.6.4-pl1-1 |
phpmyadminDebian:14 |
before 4:2.6.4-pl1-1 | 4:2.6.4-pl1-1 |
phpmyadminDebian:3.0 From an advisory covering 4 CVEs |
All versions, plus listed versions 2.2.3-13:2.6.1-pl2-13:2.6.1-pl3-13:2.6.1-pl3-23:2.6.2-rc1-1 Show 45 moreShow less4:2.10.0.2-14:2.10.1-14:2.10.1-24:2.10.1-34:2.10.2-14:2.10.3-14:2.11.0-14:2.11.1-14:2.11.1.2-14:2.11.2-14:2.11.2-24:2.11.2.1-14:2.11.2.2-14:2.11.3-14:2.11.3-24:2.11.4-14:2.11.5-14:2.11.5.1-14:2.11.5.2-14:2.11.6-14:2.11.7-14:2.11.7.1-14:2.11.7~rc2-14:2.11.8.1-14:2.11.8.1-24:2.11.8.1-34:2.11.8.1-44:2.11.8.1-54:2.11.8.1-5+lenny14:2.11.8.1-5+lenny34:2.11.8.1-5+lenny44:2.11.8.1-5+lenny54:2.11.8.1-5+lenny64:2.11.8.1-5+lenny74:2.11.8.1-5+lenny84:2.11.8.1-5+lenny94:2.11.8~rc1-14:2.6.2-14:2.6.2-24:2.6.2-34:2.6.2-3sarge14:2.6.2-3sarge24:2.6.2-3sarge34:2.6.2-3sarge44:2.6.2-3sarge5 |
None known |
phpmyadminDebian:3.1 From an advisory covering 4 CVEs |
before 4:2.6.2-3sarge1, plus listed versions 4:2.6.2-3 |
4:2.6.2-3sarge1 |
phpMyAdminopenSUSE:Tumbleweed From an advisory covering 31 CVEs |
before 5.1.1-1.2 | 5.1.1-1.2 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | phpMyAdmin 2.x - 'error.php' Cross-Site Scripting | 2005-08-28 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2005-2869 is a medium vulnerability (CVSS 4.3) in Phpmyadmin, published September 8, 2005. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 5.09%, the 92nd percentile. Fixed in phpmyadmin 4:2.6.4-pl1-1.
References
novell.com/linux/security/advisories/2005_28_sr.html
novell.com/linux/security/advisories/2005_66_phpmyadmin.html
sourceforge.net/tracker/index.php?func=detail&aid=1265740&group_id=23067&atid=377408
secunia.com/advisories/17607
secunia.com/advisories/17559
sourceforge.net/tracker/index.php?func=detail&aid=1240880&group_id=23067&atid=377408
Show 37 moreShow less
debian.org/security/2005/dsa-880
secunia.com/advisories/17337
secunia.com/advisories/16605
nvd.nist.gov/vuln/detail/CVE-2005-2869
github.com/advisories/GHSA-f47h-66wf-9744
security-tracker.debian.org/tracker/CVE-2005-2869
suse.com/security/cve/CVE-2005-2869
suse.com/security/cve/CVE-2006-1804
suse.com/security/cve/CVE-2006-2031
suse.com/security/cve/CVE-2015-8980
suse.com/security/cve/CVE-2017-1000013
suse.com/security/cve/CVE-2017-1000014
suse.com/security/cve/CVE-2017-1000015
suse.com/security/cve/CVE-2017-1000016
suse.com/security/cve/CVE-2017-1000017
suse.com/security/cve/CVE-2017-1000018
suse.com/security/cve/CVE-2017-1000499
suse.com/security/cve/CVE-2018-10188
suse.com/security/cve/CVE-2018-12581
suse.com/security/cve/CVE-2018-12613
suse.com/security/cve/CVE-2018-15605
suse.com/security/cve/CVE-2018-19968
suse.com/security/cve/CVE-2018-19969
suse.com/security/cve/CVE-2018-19970
suse.com/security/cve/CVE-2018-7260
suse.com/security/cve/CVE-2019-11768
suse.com/security/cve/CVE-2019-12616
suse.com/security/cve/CVE-2019-12922
suse.com/security/cve/CVE-2019-18622
suse.com/security/cve/CVE-2019-6798
suse.com/security/cve/CVE-2019-6799
suse.com/security/cve/CVE-2020-10802
suse.com/security/cve/CVE-2020-10803
suse.com/security/cve/CVE-2020-10804
suse.com/security/cve/CVE-2020-26934
suse.com/security/cve/CVE-2020-26935
suse.com/security/cve/CVE-2020-5504
Left out here: 231 versions. The JSON record has them.