CVE-2006-0146
The server.php test script in ADOdb for PHP before 4.70, as used in multiple products including ...
The server.php test script in ADOdb for PHP before 4.70, as used in multiple products including (1) Mantis, (2) PostNuke, (3) Moodle, (4) Cacti, (5) Xaraya, (6) PHPOpenChat, (7) MAXdev MD-Pro, and (8) MediaBeez, when the MySQL root password is empty, allows remote attackers to execute arbitrary SQL commands via the sql parameter.
Exploit likelihood
What each source reports
NVD Score used
7.5
The server.php test script in ADOdb for PHP before 4.70, as used in multiple products including (1) Mantis, (2) PostNuke, (3) Moodle, (4) Cacti, (5) Xaraya, (6) PHPOpenChat, (7) MAXdev MD-Pro, and (8) MediaBeez, when the MySQL root password is empty, allows remote attackers to execute arbitrary SQL commands via the sql parameter.
- Record
CVE-2006-0146- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List No score
The server.php test script in ADOdb for PHP before 4.70, as used in multiple products including (1) Mantis, (2) PostNuke, (3) Moodle, (4) Cacti, (5) Xaraya, (6) PHPOpenChat, (7) MAXdev MD-Pro, and (8) MediaBeez, when the MySQL root password is empty, allows remote attackers to execute arbitrary SQL commands via the sql parameter.
- Record
CVE-2006-0146- Updated
- 2026-11-02
EUVDEUVD-2006-0154 No score
The server.php test script in ADOdb for PHP before 4.70, as used in multiple products including (1) Mantis, (2) PostNuke, (3) Moodle, (4) Cacti, (5) Xaraya, (6) PHPOpenChat, (7) MAXdev MD-Pro, and (8) MediaBeez, when the MySQL root password is empty, allows remote attackers to execute arbitrary SQL commands via the sql parameter.
- Record
EUVD-2006-0154- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q9q3-j7rw-3j95 No score
The server.php test script in ADOdb for PHP before 4.70, as used in multiple products including ...
The server.php test script in ADOdb for PHP before 4.70, as used in multiple products including (1) Mantis, (2) PostNuke, (3) Moodle, (4) Cacti, (5) Xaraya, (6) PHPOpenChat, (7) MAXdev MD-Pro, and (8) MediaBeez, when the MySQL root password is empty, allows remote attackers to execute arbitrary SQL commands via the sql parameter.
- Record
GHSA-q9q3-j7rw-3j95- Weakness
- CWE-89
- Updated
- 2026-11-02
OSV No score
The server.php test script in ADOdb for PHP before 4.70, as used in multiple products including (1) Mantis, (2) PostNuke, (3) Moodle, (4) Cacti, (5) Xaraya, (6) PHPOpenChat, (7) MAXdev MD-Pro, and (8) MediaBeez, when the MySQL root password is empty, allows remote attackers to execute arbitrary SQL commands via the sql parameter.
- Record
CVE-2006-0146- Updated
- 2026-11-02
OSVDEBIAN-CVE-2006-0146 No score
The server.php test script in ADOdb for PHP before 4.70, as used in multiple products including (1) Mantis, (2) PostNuke, (3) Moodle, (4) Cacti, (5) Xaraya, (6) PHPOpenChat, (7) MAXdev MD-Pro, and (8) MediaBeez, when the MySQL root password is empty, allows remote attackers to execute arbitrary SQL commands via the sql parameter.
- Record
DEBIAN-CVE-2006-0146- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cactiDebian:12 |
before 0.8.6d-1 | 0.8.6d-1 |
cactiDebian:13 |
before 0.8.6d-1 | 0.8.6d-1 |
cactiDebian:14 |
before 0.8.6d-1 | 0.8.6d-1 |
libphp-adodbDebian:12 |
before 4.72-0.1 | 4.72-0.1 |
libphp-adodbDebian:13 |
before 4.72-0.1 | 4.72-0.1 |
libphp-adodbDebian:14 |
before 4.72-0.1 | 4.72-0.1 |
libphp-adodbDebian:3.0 From an advisory covering 4 CVEs |
before 1.51-1.2, plus listed versions 1.51-1.1 |
1.51-1.2 |
libphp-adodbDebian:3.1 From an advisory covering 4 CVEs |
before 4.52-1sarge1, plus listed versions 4.52-1 |
4.52-1sarge1 |
moodleDebian:3.1 From an advisory covering 4 CVEs |
before 1.4.4.dfsg.1-3sarge1, plus listed versions 1.4.4.dfsg.1-3 |
1.4.4.dfsg.1-3sarge1 |
cactiDebian:3.1 From an advisory covering 4 CVEs |
before 0.8.6c-7sarge3, plus listed versions 0.8.6c-70.8.6c-7sarge2 |
0.8.6c-7sarge3 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Simplog 0.9.2 - 's' Remote Command Execution | 2006-04-11 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2006-0146 is a high vulnerability (CVSS 7.5) in John Lim Adodb, published January 9, 2006. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 13.2%, the 96th percentile. Fixed in cacti 0.8.6d-1.
References
secunia.com/advisories/19590
secunia.com/advisories/18267
secunia.com/advisories/18254
secunia.com/advisories/19555
debian.org/security/2006/dsa-1029
securityfocus.com/archive/1/430448/100/0/threaded
Show 37 moreShow less
maxdev.com/Article550.phtml
vupen.com/english/advisories/2006/0105
secunia.com/advisories/19699
debian.org/security/2006/dsa-1030
vupen.com/english/advisories/2006/1305
secunia.com/advisories/24954
secunia.com/advisories/18276
securityreason.com/securityalert/713
vupen.com/english/advisories/2006/1304
secunia.com/advisories/19600
securityfocus.com/archive/1/466171/100/0/threaded
vupen.com/english/advisories/2006/0103
secunia.com/secunia_research/2005-64/advisory
securityfocus.com/bid/16187
secunia.com/advisories/18720
vupen.com/english/advisories/2006/1419
secunia.com/advisories/19591
vupen.com/english/advisories/2006/0447
exchange.xforce.ibmcloud.com/vulnerabilities/24051
secunia.com/advisories/17418
xaraya.com/index.php/news/569
secunia.com/advisories/19691
vupen.com/english/advisories/2006/0102
vupen.com/english/advisories/2006/0101
secunia.com/advisories/18233
osvdb.org/22290
vupen.com/english/advisories/2006/0370
debian.org/security/2006/dsa-1031
retrogod.altervista.org/phpopenchat_30x_sql_xpl.html
securityfocus.com/archive/1/423784/100/0/threaded
vupen.com/english/advisories/2006/0104
secunia.com/advisories/18260
gentoo.org/security/en/glsa/glsa-200604-07.xml
secunia.com/advisories/19563
nvd.nist.gov/vuln/detail/CVE-2006-0146
github.com/advisories/GHSA-q9q3-j7rw-3j95
security-tracker.debian.org/tracker/CVE-2006-0146