Every CVE Search/ Get API key

CVE-2006-1010

Buffer overflow in socket/request.c in CrossFire before 1.9.0, when oldsocketmode is enabled,...

6.4 MediumPublic exploitFix available

Buffer overflow in socket/request.c in CrossFire before 1.9.0, when oldsocketmode is enabled, allows remote attackers to cause a denial of service (segmentation fault) and possibly execute code by sending the server a large request.

Exploit likelihood

17.6%Down 17.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.4

Buffer overflow in socket/request.c in CrossFire before 1.9.0, when oldsocketmode is enabled, allows remote attackers to cause a denial of service (segmentation fault) and possibly execute code by sending the server a large request.

Record
CVE-2006-1010
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:N/I:P/A:P
Updated
2026-11-02
CVE List No score

Buffer overflow in socket/request.c in CrossFire before 1.9.0, when oldsocketmode is enabled, allows remote attackers to cause a denial of service (segmentation fault) and possibly execute code by sending the server a large request.

Record
CVE-2006-1010
Updated
2026-11-02
EUVDEUVD-2006-1014 No score

Buffer overflow in socket/request.c in CrossFire before 1.9.0, when oldsocketmode is enabled, allows remote attackers to cause a denial of service (segmentation fault) and possibly execute code by sending the server a large request.

Record
EUVD-2006-1014
Updated
2026-11-03
GitHub AdvisoriesGHSA-9gcr-358p-mv64 No score

Buffer overflow in socket/request.c in CrossFire before 1.9.0, when oldsocketmode is enabled,...

Buffer overflow in socket/request.c in CrossFire before 1.9.0, when oldsocketmode is enabled, allows remote attackers to cause a denial of service (segmentation fault) and possibly execute code by sending the server a large request.

Record
GHSA-9gcr-358p-mv64
Updated
2026-11-02
OSV No score

Buffer overflow in socket/request.c in CrossFire before 1.9.0, when oldsocketmode is enabled, allows remote attackers to cause a denial of service (segmentation fault) and possibly execute code by sending the server a large request.

Record
CVE-2006-1010
Updated
2026-11-02
OSVDEBIAN-CVE-2006-1010 No score

Buffer overflow in socket/request.c in CrossFire before 1.9.0, when oldsocketmode is enabled, allows remote attackers to cause a denial of service (segmentation fault) and possibly execute code by sending the server a large request.

Record
DEBIAN-CVE-2006-1010
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
crossfire
Debian:12
before 1.9.0-1
1.9.0-1
crossfire
Debian:13
before 1.9.0-1
1.9.0-1
crossfire
Debian:14
before 1.9.0-1
1.9.0-1
crossfire
Debian:3.0
before 1.1.0-1woody1, plus listed versions
1.1.0-1
1.1.0-1woody1
crossfire
Debian:3.1
before 1.6.0.dfsg.1-4sarge1, plus listed versions
1.6.0.dfsg.1-4
1.6.0.dfsg.1-4sarge1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBCrossFire 1.8.0 - 'oldsocketmode' Remote Buffer Overflow (PoC)2006-02-27

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-1010 is a medium vulnerability (CVSS 6.4) in Crossfire, published March 6, 2006. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 17.6%, the 97th percentile. Fixed in crossfire 1.9.0-1.

References

Show 8 moreShow less
MoveEnter Open