Every CVE Search/ Get API key

CVE-2006-2842

** DISPUTED ** PHP remote file inclusion vulnerability in functions/plugin.php in SquirrelMail 1...

7.5 HighPublic exploitFix availableDisputed

PHP remote file inclusion vulnerability in functions/plugin.php in SquirrelMail 1.4.6 and earlier, if register_globals is enabled and magic_quotes_gpc is disabled, allows remote attackers to execute arbitrary PHP code via a URL in the plugins array parameter. NOTE: this issue has been disputed by third parties, who state that Squirrelmail provides prominent warnings to the administrator when register_globals is enabled. Since the varieties of administrator negligence are uncountable, perhaps this type of issue should not be included in CVE. However, the original developer has posted a security advisory, so there might be relevant real-world environments under which this vulnerability is applicable

Exploit likelihood

47.2%Up 34.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

PHP remote file inclusion vulnerability in functions/plugin.php in SquirrelMail 1.4.6 and earlier, if register_globals is enabled and magic_quotes_gpc is disabled, allows remote attackers to execute arbitrary PHP code via a URL in the plugins array parameter. NOTE: this issue has been disputed by third parties, who state that Squirrelmail provides prominent warnings to the administrator when register_globals is enabled. Since the varieties of administrator negligence are uncountable, perhaps this type of issue should not be included in CVE. However, the original developer has posted a security advisory, so there might be relevant real-world environments under which this vulnerability is applicable

Record
CVE-2006-2842
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

PHP remote file inclusion vulnerability in functions/plugin.php in SquirrelMail 1.4.6 and earlier, if register_globals is enabled and magic_quotes_gpc is disabled, allows remote attackers to execute arbitrary PHP code via a URL in the plugins array parameter. NOTE: this issue has been disputed by third parties, who state that Squirrelmail provides prominent warnings to the administrator when register_globals is enabled. Since the varieties of administrator negligence are uncountable, perhaps this type of issue should not be included in CVE. However, the original developer has posted a security advisory, so there might be relevant real-world environments under which this vulnerability is applicable

Record
CVE-2006-2842
Updated
2026-11-02
EUVDEUVD-2006-2839 No score

PHP remote file inclusion vulnerability in functions/plugin.php in SquirrelMail 1.4.6 and earlier, if register_globals is enabled and magic_quotes_gpc is disabled, allows remote attackers to execute arbitrary PHP code via a URL in the plugins array parameter. NOTE: this issue has been disputed by third parties, who state that Squirrelmail provides prominent warnings to the administrator when register_globals is enabled. Since the varieties of administrator negligence are uncountable, perhaps this type of issue should not be included in CVE. However, the original developer has posted a security advisory, so there might be relevant real-world environments under which this vulnerability is applicable

Record
EUVD-2006-2839
Updated
2026-11-03
GitHub AdvisoriesGHSA-h9qp-9p74-vrxm No score

** DISPUTED ** PHP remote file inclusion vulnerability in functions/plugin.php in SquirrelMail 1...

** DISPUTED ** PHP remote file inclusion vulnerability in functions/plugin.php in SquirrelMail 1.4.6 and earlier, if register_globals is enabled and magic_quotes_gpc is disabled, allows remote attackers to execute arbitrary PHP code via a URL in the plugins array parameter. NOTE: this issue has been disputed by third parties, who state that Squirrelmail provides prominent warnings to the administrator when register_globals is enabled. Since the varieties of administrator negligence are uncountable, perhaps this type of issue should not be included in CVE. However, the original developer has posted a security advisory, so there might be relevant real-world environments under which this vulnerability is applicable.

Record
GHSA-h9qp-9p74-vrxm
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
squirrelmail
Red Hat:enterprise_linux:3::as
before 0:1.4.6-7.el3
0:1.4.6-7.el3
squirrelmail
Red Hat:enterprise_linux:3::desktop
before 0:1.4.6-7.el3
0:1.4.6-7.el3
squirrelmail
Red Hat:enterprise_linux:3::es
before 0:1.4.6-7.el3
0:1.4.6-7.el3
squirrelmail
Red Hat:enterprise_linux:3::ws
before 0:1.4.6-7.el3
0:1.4.6-7.el3
squirrelmail
Red Hat:enterprise_linux:4::as
before 0:1.4.6-7.el4
0:1.4.6-7.el4
squirrelmail
Red Hat:enterprise_linux:4::desktop
before 0:1.4.6-7.el4
0:1.4.6-7.el4
squirrelmail
Red Hat:enterprise_linux:4::es
before 0:1.4.6-7.el4
0:1.4.6-7.el4
squirrelmail
Red Hat:enterprise_linux:4::ws
before 0:1.4.6-7.el4
0:1.4.6-7.el4

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-2842 is a high vulnerability (CVSS 7.5) in Squirrelmail, published June 6, 2006. Its validity is disputed. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 47.2%, the 98th percentile. Fixed in squirrelmail 0:1.4.6-7.el3.

References

Show 23 moreShow less
MoveEnter Open