Every CVE Search/ Get API key

CVE-2006-3628

Multiple format string vulnerabilities in Wireshark (aka Ethereal) 0.10.x to 0.99.0 allow remote...

10.0 HighFix available

Multiple format string vulnerabilities in Wireshark (aka Ethereal) 0.10.x to 0.99.0 allow remote attackers to cause a denial of service and possibly execute arbitrary code via the (1) ANSI MAP, (2) Checkpoint FW-1, (3) MQ, (4) XML, and (5) NTP dissectors.

Exploit likelihood

6.04%Down 2.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

Multiple format string vulnerabilities in Wireshark (aka Ethereal) 0.10.x to 0.99.0 allow remote attackers to cause a denial of service and possibly execute arbitrary code via the (1) ANSI MAP, (2) Checkpoint FW-1, (3) MQ, (4) XML, and (5) NTP dissectors.

Record
CVE-2006-3628
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-134
Updated
2026-11-02
CVE List No score

Multiple format string vulnerabilities in Wireshark (aka Ethereal) 0.10.x to 0.99.0 allow remote attackers to cause a denial of service and possibly execute arbitrary code via the (1) ANSI MAP, (2) Checkpoint FW-1, (3) MQ, (4) XML, and (5) NTP dissectors.

Record
CVE-2006-3628
Updated
2026-11-02
EUVDEUVD-2006-3623 No score

Multiple format string vulnerabilities in Wireshark (aka Ethereal) 0.10.x to 0.99.0 allow remote attackers to cause a denial of service and possibly execute arbitrary code via the (1) ANSI MAP, (2) Checkpoint FW-1, (3) MQ, (4) XML, and (5) NTP dissectors.

Record
EUVD-2006-3623
Updated
2026-11-03
GitHub AdvisoriesGHSA-mg6c-c5w2-g567 No score

Multiple format string vulnerabilities in Wireshark (aka Ethereal) 0.10.x to 0.99.0 allow remote...

Multiple format string vulnerabilities in Wireshark (aka Ethereal) 0.10.x to 0.99.0 allow remote attackers to cause a denial of service and possibly execute arbitrary code via the (1) ANSI MAP, (2) Checkpoint FW-1, (3) MQ, (4) XML, and (5) NTP dissectors.

Record
GHSA-mg6c-c5w2-g567
Weakness
CWE-134
Updated
2026-11-02
OSV No score

Multiple format string vulnerabilities in Wireshark (aka Ethereal) 0.10.x to 0.99.0 allow remote attackers to cause a denial of service and possibly execute arbitrary code via the (1) ANSI MAP, (2) Checkpoint FW-1, (3) MQ, (4) XML, and (5) NTP dissectors.

Record
CVE-2006-3628
Updated
2026-11-02
OSVDEBIAN-CVE-2006-3628 No score

Multiple format string vulnerabilities in Wireshark (aka Ethereal) 0.10.x to 0.99.0 allow remote attackers to cause a denial of service and possibly execute arbitrary code via the (1) ANSI MAP, (2) Checkpoint FW-1, (3) MQ, (4) XML, and (5) NTP dissectors.

Record
DEBIAN-CVE-2006-3628
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wireshark
Debian:12
before 0.99.2-1
0.99.2-1
wireshark
Debian:13
before 0.99.2-1
0.99.2-1
wireshark
Debian:14
before 0.99.2-1
0.99.2-1
ethereal
Debian:3.1
From an advisory covering 5 CVEs
before 0.10.10-2sarge6, plus listed versions
0.10.10-2sarge20.10.10-2sarge30.10.10-2sarge40.10.10-2sarge5
0.10.10-2sarge6
wireshark
Red Hat:enterprise_linux:3::as
From an advisory covering 6 CVEs
before 0:0.99.2-EL3.1
0:0.99.2-EL3.1
wireshark-debuginfo
Red Hat:enterprise_linux:3::as
From an advisory covering 6 CVEs
before 0:0.99.2-EL3.1
0:0.99.2-EL3.1
wireshark-gnome
Red Hat:enterprise_linux:3::as
From an advisory covering 6 CVEs
before 0:0.99.2-EL3.1
0:0.99.2-EL3.1
wireshark
Red Hat:enterprise_linux:3::desktop
From an advisory covering 6 CVEs
before 0:0.99.2-EL3.1
0:0.99.2-EL3.1
wireshark-debuginfo
Red Hat:enterprise_linux:3::desktop
From an advisory covering 6 CVEs
before 0:0.99.2-EL3.1
0:0.99.2-EL3.1
wireshark-gnome
Red Hat:enterprise_linux:3::desktop
From an advisory covering 6 CVEs
before 0:0.99.2-EL3.1
0:0.99.2-EL3.1
Show 18 moreShow less
Affected packages
PackageAffectedFixed
wireshark
Red Hat:enterprise_linux:3::es
From an advisory covering 6 CVEs
before 0:0.99.2-EL3.1
0:0.99.2-EL3.1
wireshark-debuginfo
Red Hat:enterprise_linux:3::es
From an advisory covering 6 CVEs
before 0:0.99.2-EL3.1
0:0.99.2-EL3.1
wireshark-gnome
Red Hat:enterprise_linux:3::es
From an advisory covering 6 CVEs
before 0:0.99.2-EL3.1
0:0.99.2-EL3.1
wireshark
Red Hat:enterprise_linux:3::ws
From an advisory covering 6 CVEs
before 0:0.99.2-EL3.1
0:0.99.2-EL3.1
wireshark-debuginfo
Red Hat:enterprise_linux:3::ws
From an advisory covering 6 CVEs
before 0:0.99.2-EL3.1
0:0.99.2-EL3.1
wireshark-gnome
Red Hat:enterprise_linux:3::ws
From an advisory covering 6 CVEs
before 0:0.99.2-EL3.1
0:0.99.2-EL3.1
wireshark
Red Hat:enterprise_linux:4::as
From an advisory covering 6 CVEs
before 0:0.99.2-EL4.1
0:0.99.2-EL4.1
wireshark-debuginfo
Red Hat:enterprise_linux:4::as
From an advisory covering 6 CVEs
before 0:0.99.2-EL4.1
0:0.99.2-EL4.1
wireshark-gnome
Red Hat:enterprise_linux:4::as
From an advisory covering 6 CVEs
before 0:0.99.2-EL4.1
0:0.99.2-EL4.1
wireshark
Red Hat:enterprise_linux:4::desktop
From an advisory covering 6 CVEs
before 0:0.99.2-EL4.1
0:0.99.2-EL4.1
wireshark-debuginfo
Red Hat:enterprise_linux:4::desktop
From an advisory covering 6 CVEs
before 0:0.99.2-EL4.1
0:0.99.2-EL4.1
wireshark-gnome
Red Hat:enterprise_linux:4::desktop
From an advisory covering 6 CVEs
before 0:0.99.2-EL4.1
0:0.99.2-EL4.1
wireshark
Red Hat:enterprise_linux:4::es
From an advisory covering 6 CVEs
before 0:0.99.2-EL4.1
0:0.99.2-EL4.1
wireshark-debuginfo
Red Hat:enterprise_linux:4::es
From an advisory covering 6 CVEs
before 0:0.99.2-EL4.1
0:0.99.2-EL4.1
wireshark-gnome
Red Hat:enterprise_linux:4::es
From an advisory covering 6 CVEs
before 0:0.99.2-EL4.1
0:0.99.2-EL4.1
wireshark
Red Hat:enterprise_linux:4::ws
From an advisory covering 6 CVEs
before 0:0.99.2-EL4.1
0:0.99.2-EL4.1
wireshark-debuginfo
Red Hat:enterprise_linux:4::ws
From an advisory covering 6 CVEs
before 0:0.99.2-EL4.1
0:0.99.2-EL4.1
wireshark-gnome
Red Hat:enterprise_linux:4::ws
From an advisory covering 6 CVEs
before 0:0.99.2-EL4.1
0:0.99.2-EL4.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-3628 is a high vulnerability (CVSS 10.0) in Ethereal Group Ethereal, published July 18, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.04%, the 93rd percentile. Fixed in wireshark 0.99.2-1.

References

Show 57 moreShow less
MoveEnter Open