CVE-2006-4002
Cross-site scripting (XSS) vulnerability in user.module in Drupal 4.6 before 4.6.9, and 4.7...
Cross-site scripting (XSS) vulnerability in user.module in Drupal 4.6 before 4.6.9, and 4.7 before 4.7.3, allows remote attackers to inject arbitrary web script or HTML via the msg parameter. NOTE: portions of these details are obtained from third party information.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in user.module in Drupal 4.6 before 4.6.9, and 4.7 before 4.7.3, allows remote attackers to inject arbitrary web script or HTML via the msg parameter. NOTE: portions of these details are obtained from third party information.
- Record
CVE-2006-4002- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in user.module in Drupal 4.6 before 4.6.9, and 4.7 before 4.7.3, allows remote attackers to inject arbitrary web script or HTML via the msg parameter. NOTE: portions of these details are obtained from third party information.
- Record
CVE-2006-4002- Updated
- 2026-11-02
EUVDEUVD-2006-3995 No score
Cross-site scripting (XSS) vulnerability in user.module in Drupal 4.6 before 4.6.9, and 4.7 before 4.7.3, allows remote attackers to inject arbitrary web script or HTML via the msg parameter. NOTE: portions of these details are obtained from third party information.
- Record
EUVD-2006-3995- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3837-2vcf-c962 No score
Cross-site scripting (XSS) vulnerability in user.module in Drupal 4.6 before 4.6.9, and 4.7...
Cross-site scripting (XSS) vulnerability in user.module in Drupal 4.6 before 4.6.9, and 4.7 before 4.7.3, allows remote attackers to inject arbitrary web script or HTML via the msg parameter. NOTE: portions of these details are obtained from third party information.
- Record
GHSA-3837-2vcf-c962- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
drupalDebian:3.1 |
before 4.5.3-6.1sarge3, plus listed versions 4.5.3-24.5.3-34.5.3-44.5.3-54.5.3-64.5.3-6.1sarge14.5.3-6.1sarge2 |
4.5.3-6.1sarge3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2006-4002 is a medium vulnerability (CVSS 4.3) in Drupal, published August 7, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.37%, the 72nd percentile. Fixed in drupal 4.5.3-6.1sarge3.
References
exchange.xforce.ibmcloud.com/vulnerabilities/28184
vupen.com/english/advisories/2006/3138
secunia.com/advisories/21503
debian.org/security/2006/dsa-1147
drupal.org/node/76748
securityfocus.com/bid/19325
secunia.com/advisories/21332
nvd.nist.gov/vuln/detail/CVE-2006-4002
github.com/advisories/GHSA-3837-2vcf-c962