CVE-2006-4808
Heap-based buffer overflow in loader_tga.c in imlib2 before 1.2.1, and possibly other versions,...
Heap-based buffer overflow in loader_tga.c in imlib2 before 1.2.1, and possibly other versions, allows user-assisted remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted TGA image.
Exploit likelihood
What each source reports
NVD Score used
2.6
Heap-based buffer overflow in loader_tga.c in imlib2 before 1.2.1, and possibly other versions, allows user-assisted remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted TGA image.
- Record
CVE-2006-4808- CVSS 2.0
- 2.6 Low
AV:N/AC:H/Au:N/C:N/I:N/A:P - Updated
- 2026-11-02
CVE List No score
Heap-based buffer overflow in loader_tga.c in imlib2 before 1.2.1, and possibly other versions, allows user-assisted remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted TGA image.
- Record
CVE-2006-4808- Updated
- 2026-11-02
EUVDEUVD-2006-4795 No score
Heap-based buffer overflow in loader_tga.c in imlib2 before 1.2.1, and possibly other versions, allows user-assisted remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted TGA image.
- Record
EUVD-2006-4795- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hcr5-cf9m-7gf4 No score
Heap-based buffer overflow in loader_tga.c in imlib2 before 1.2.1, and possibly other versions,...
Heap-based buffer overflow in loader_tga.c in imlib2 before 1.2.1, and possibly other versions, allows user-assisted remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted TGA image.
- Record
GHSA-hcr5-cf9m-7gf4- Updated
- 2026-11-02
OSV No score
Heap-based buffer overflow in loader_tga.c in imlib2 before 1.2.1, and possibly other versions, allows user-assisted remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted TGA image.
- Record
CVE-2006-4808- Updated
- 2026-11-02
OSVDEBIAN-CVE-2006-4808 No score
Heap-based buffer overflow in loader_tga.c in imlib2 before 1.2.1, and possibly other versions, allows user-assisted remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted TGA image.
- Record
DEBIAN-CVE-2006-4808- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2006-4808 is a low vulnerability (CVSS 2.6) in Enlightenment Imlib2, published November 7, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.46%, the 91st percentile. Fixed in imlib2 1.3.0.0debian1-3.
References
exchange.xforce.ibmcloud.com/vulnerabilities/30068
secunia.com/advisories/22932
mandriva.com/security/advisories?name=MDKSA-2007:156
secunia.com/advisories/22752
mandriva.com/security/advisories?name=MDKSA-2006:198
novell.com/linux/security/advisories/2006_26_sr.html
Show 13 moreShow less
securityfocus.com/bid/20903
discontinuity.info/~rowan/pocs/libimlib2_pocs-1.2.0-2.2.tar.gz
ubuntu.com/usn/usn-376-2
security.gentoo.org/glsa/glsa-200612-20.xml
vupen.com/english/advisories/2006/4349
secunia.com/advisories/23441
osvdb.org/30103
secunia.com/advisories/22732
secunia.com/advisories/22744
ubuntu.com/usn/usn-376-1
nvd.nist.gov/vuln/detail/CVE-2006-4808
github.com/advisories/GHSA-hcr5-cf9m-7gf4
security-tracker.debian.org/tracker/CVE-2006-4808