Every CVE Search/ Get API key

CVE-2006-5111

The libksba library 0.9.12 and possibly other versions, as used by gpgsm in the newpg package on...

5.0 MediumFix available

The libksba library 0.9.12 and possibly other versions, as used by gpgsm in the newpg package on SUSE LINUX, allows attackers to cause a denial of service (application crash) via a malformed X.509 certificate in a signature.

Exploit likelihood

1.93%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The libksba library 0.9.12 and possibly other versions, as used by gpgsm in the newpg package on SUSE LINUX, allows attackers to cause a denial of service (application crash) via a malformed X.509 certificate in a signature.

Record
CVE-2006-5111
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

The libksba library 0.9.12 and possibly other versions, as used by gpgsm in the newpg package on SUSE LINUX, allows attackers to cause a denial of service (application crash) via a malformed X.509 certificate in a signature.

Record
CVE-2006-5111
Updated
2026-11-02
EUVDEUVD-2006-5096 No score

The libksba library 0.9.12 and possibly other versions, as used by gpgsm in the newpg package on SUSE LINUX, allows attackers to cause a denial of service (application crash) via a malformed X.509 certificate in a signature.

Record
EUVD-2006-5096
Updated
2026-11-03
GitHub AdvisoriesGHSA-hh6w-9c5q-qw82 No score

The libksba library 0.9.12 and possibly other versions, as used by gpgsm in the newpg package on...

The libksba library 0.9.12 and possibly other versions, as used by gpgsm in the newpg package on SUSE LINUX, allows attackers to cause a denial of service (application crash) via a malformed X.509 certificate in a signature.

Record
GHSA-hh6w-9c5q-qw82
Updated
2026-11-02
OSV No score

The libksba library 0.9.12 and possibly other versions, as used by gpgsm in the newpg package on SUSE LINUX, allows attackers to cause a denial of service (application crash) via a malformed X.509 certificate in a signature.

Record
CVE-2006-5111
Updated
2026-11-02
OSVDEBIAN-CVE-2006-5111 No score

The libksba library 0.9.12 and possibly other versions, as used by gpgsm in the newpg package on SUSE LINUX, allows attackers to cause a denial of service (application crash) via a malformed X.509 certificate in a signature.

Record
DEBIAN-CVE-2006-5111
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libksba
Debian:12
before 0.9.14-1
0.9.14-1
libksba
Debian:13
before 0.9.14-1
0.9.14-1
libksba
Debian:14
before 0.9.14-1
0.9.14-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-5111 is a medium vulnerability (CVSS 5.0) in Libksba Library Library, published October 2, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.93%, the 80th percentile. Fixed in libksba 0.9.14-1.

References

Show 6 moreShow less
MoveEnter Open