Every CVE Search/ Get API key

CVE-2006-5989

Off-by-one error in the der_get_oid function in mod_auth_kerb 5.0 allows remote attackers to...

5.0 MediumFix available

Off-by-one error in the der_get_oid function in mod_auth_kerb 5.0 allows remote attackers to cause a denial of service (crash) via a crafted Kerberos message that triggers a heap-based buffer overflow in the component array.

Exploit likelihood

3.96%Up 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Off-by-one error in the der_get_oid function in mod_auth_kerb 5.0 allows remote attackers to cause a denial of service (crash) via a crafted Kerberos message that triggers a heap-based buffer overflow in the component array.

Record
CVE-2006-5989
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

Off-by-one error in the der_get_oid function in mod_auth_kerb 5.0 allows remote attackers to cause a denial of service (crash) via a crafted Kerberos message that triggers a heap-based buffer overflow in the component array.

Record
CVE-2006-5989
Updated
2026-11-02
EUVDEUVD-2006-5972 No score

Off-by-one error in the der_get_oid function in mod_auth_kerb 5.0 allows remote attackers to cause a denial of service (crash) via a crafted Kerberos message that triggers a heap-based buffer overflow in the component array.

Record
EUVD-2006-5972
Updated
2026-11-03
GitHub AdvisoriesGHSA-f5v5-ggh9-mj78 No score

Off-by-one error in the der_get_oid function in mod_auth_kerb 5.0 allows remote attackers to...

Off-by-one error in the der_get_oid function in mod_auth_kerb 5.0 allows remote attackers to cause a denial of service (crash) via a crafted Kerberos message that triggers a heap-based buffer overflow in the component array.

Record
GHSA-f5v5-ggh9-mj78
Updated
2026-11-02
OSV No score

Off-by-one error in the der_get_oid function in mod_auth_kerb 5.0 allows remote attackers to cause a denial of service (crash) via a crafted Kerberos message that triggers a heap-based buffer overflow in the component array.

Record
CVE-2006-5989
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libapache-mod-auth-kerb
Debian:3.1
before 4.996-5.0-rc6-1sarge1, plus listed versions
4.996-5.0-rc6-1
4.996-5.0-rc6-1sarge1
mod_auth_kerb
Red Hat:enterprise_linux:4::as
before 0:5.0-1.3
0:5.0-1.3
mod_auth_kerb-debuginfo
Red Hat:enterprise_linux:4::as
before 0:5.0-1.3
0:5.0-1.3
mod_auth_kerb
Red Hat:enterprise_linux:4::desktop
before 0:5.0-1.3
0:5.0-1.3
mod_auth_kerb-debuginfo
Red Hat:enterprise_linux:4::desktop
before 0:5.0-1.3
0:5.0-1.3
mod_auth_kerb
Red Hat:enterprise_linux:4::es
before 0:5.0-1.3
0:5.0-1.3
mod_auth_kerb-debuginfo
Red Hat:enterprise_linux:4::es
before 0:5.0-1.3
0:5.0-1.3
mod_auth_kerb
Red Hat:enterprise_linux:4::ws
before 0:5.0-1.3
0:5.0-1.3
mod_auth_kerb-debuginfo
Red Hat:enterprise_linux:4::ws
before 0:5.0-1.3
0:5.0-1.3

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-5989 is a medium vulnerability (CVSS 5.0) in Mod Auth Kerb Auth Kerb, published November 20, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.96%, the 90th percentile. Fixed in libapache-mod-auth-kerb 4.996-5.0-rc6-1sarge1.

References

Show 18 moreShow less
MoveEnter Open