Every CVE Search/ Get API key

CVE-2006-6235

A "stack overwrite" vulnerability in GnuPG (gpg) 1.x before 1.4.6, 2.x before 2.0.2, and 1.9.0...

10.0 HighFix available

A "stack overwrite" vulnerability in GnuPG (gpg) 1.x before 1.4.6, 2.x before 2.0.2, and 1.9.0 through 1.9.95 allows attackers to execute arbitrary code via crafted OpenPGP packets that cause GnuPG to dereference a function pointer from deallocated stack memory.

Exploit likelihood

6.23%Up 1.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

A "stack overwrite" vulnerability in GnuPG (gpg) 1.x before 1.4.6, 2.x before 2.0.2, and 1.9.0 through 1.9.95 allows attackers to execute arbitrary code via crafted OpenPGP packets that cause GnuPG to dereference a function pointer from deallocated stack memory.

Record
CVE-2006-6235
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

A "stack overwrite" vulnerability in GnuPG (gpg) 1.x before 1.4.6, 2.x before 2.0.2, and 1.9.0 through 1.9.95 allows attackers to execute arbitrary code via crafted OpenPGP packets that cause GnuPG to dereference a function pointer from deallocated stack memory.

Record
CVE-2006-6235
Updated
2026-11-02
EUVDEUVD-2006-6218 No score

A "stack overwrite" vulnerability in GnuPG (gpg) 1.x before 1.4.6, 2.x before 2.0.2, and 1.9.0 through 1.9.95 allows attackers to execute arbitrary code via crafted OpenPGP packets that cause GnuPG to dereference a function pointer from deallocated stack memory.

Record
EUVD-2006-6218
Updated
2026-11-03
GitHub AdvisoriesGHSA-fxx3-6m2r-fwh5 No score

A "stack overwrite" vulnerability in GnuPG (gpg) 1.x before 1.4.6, 2.x before 2.0.2, and 1.9.0...

A "stack overwrite" vulnerability in GnuPG (gpg) 1.x before 1.4.6, 2.x before 2.0.2, and 1.9.0 through 1.9.95 allows attackers to execute arbitrary code via crafted OpenPGP packets that cause GnuPG to dereference a function pointer from deallocated stack memory.

Record
GHSA-fxx3-6m2r-fwh5
Updated
2026-11-02
OSV No score

A "stack overwrite" vulnerability in GnuPG (gpg) 1.x before 1.4.6, 2.x before 2.0.2, and 1.9.0 through 1.9.95 allows attackers to execute arbitrary code via crafted OpenPGP packets that cause GnuPG to dereference a function pointer from deallocated stack memory.

Record
CVE-2006-6235
Updated
2026-11-02
OSVDEBIAN-CVE-2006-6235 No score

A "stack overwrite" vulnerability in GnuPG (gpg) 1.x before 1.4.6, 2.x before 2.0.2, and 1.9.0 through 1.9.95 allows attackers to execute arbitrary code via crafted OpenPGP packets that cause GnuPG to dereference a function pointer from deallocated stack memory.

Record
DEBIAN-CVE-2006-6235
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gnupg2
Debian:12
before 2.0.0-5.2
2.0.0-5.2
gnupg2
Debian:13
before 2.0.0-5.2
2.0.0-5.2
gnupg2
Debian:14
before 2.0.0-5.2
2.0.0-5.2
gnupg
Debian:3.1
From an advisory covering 2 CVEs
before 1.4.1-1.sarge6, plus listed versions
1.4.1-11.4.1-1.sarge21.4.1-1.sarge31.4.1-1.sarge41.4.1-1.sarge51.4.1-1sarge1
1.4.1-1.sarge6
gnupg
Red Hat:enterprise_linux:2.1::as
From an advisory covering 2 CVEs
before 0:1.0.7-20
0:1.0.7-20
gnupg
Red Hat:enterprise_linux:2.1::aw
From an advisory covering 2 CVEs
before 0:1.0.7-20
0:1.0.7-20
gnupg
Red Hat:enterprise_linux:2.1::es
From an advisory covering 2 CVEs
before 0:1.0.7-20
0:1.0.7-20
gnupg
Red Hat:enterprise_linux:2.1::ws
From an advisory covering 2 CVEs
before 0:1.0.7-20
0:1.0.7-20
gnupg
Red Hat:enterprise_linux:3::as
From an advisory covering 2 CVEs
before 0:1.2.1-19
0:1.2.1-19
gnupg-debuginfo
Red Hat:enterprise_linux:3::as
From an advisory covering 2 CVEs
before 0:1.2.1-19
0:1.2.1-19
Show 14 moreShow less
Affected packages
PackageAffectedFixed
gnupg
Red Hat:enterprise_linux:3::desktop
From an advisory covering 2 CVEs
before 0:1.2.1-19
0:1.2.1-19
gnupg-debuginfo
Red Hat:enterprise_linux:3::desktop
From an advisory covering 2 CVEs
before 0:1.2.1-19
0:1.2.1-19
gnupg
Red Hat:enterprise_linux:3::es
From an advisory covering 2 CVEs
before 0:1.2.1-19
0:1.2.1-19
gnupg-debuginfo
Red Hat:enterprise_linux:3::es
From an advisory covering 2 CVEs
before 0:1.2.1-19
0:1.2.1-19
gnupg
Red Hat:enterprise_linux:3::ws
From an advisory covering 2 CVEs
before 0:1.2.1-19
0:1.2.1-19
gnupg-debuginfo
Red Hat:enterprise_linux:3::ws
From an advisory covering 2 CVEs
before 0:1.2.1-19
0:1.2.1-19
gnupg
Red Hat:enterprise_linux:4::as
From an advisory covering 2 CVEs
before 0:1.2.6-8
0:1.2.6-8
gnupg-debuginfo
Red Hat:enterprise_linux:4::as
From an advisory covering 2 CVEs
before 0:1.2.6-8
0:1.2.6-8
gnupg
Red Hat:enterprise_linux:4::desktop
From an advisory covering 2 CVEs
before 0:1.2.6-8
0:1.2.6-8
gnupg-debuginfo
Red Hat:enterprise_linux:4::desktop
From an advisory covering 2 CVEs
before 0:1.2.6-8
0:1.2.6-8
gnupg
Red Hat:enterprise_linux:4::es
From an advisory covering 2 CVEs
before 0:1.2.6-8
0:1.2.6-8
gnupg-debuginfo
Red Hat:enterprise_linux:4::es
From an advisory covering 2 CVEs
before 0:1.2.6-8
0:1.2.6-8
gnupg
Red Hat:enterprise_linux:4::ws
From an advisory covering 2 CVEs
before 0:1.2.6-8
0:1.2.6-8
gnupg-debuginfo
Red Hat:enterprise_linux:4::ws
From an advisory covering 2 CVEs
before 0:1.2.6-8
0:1.2.6-8

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-6235 is a high vulnerability (CVSS 10.0) in Gnu Privacy Guard, published December 7, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.23%, the 93rd percentile. Fixed in gnupg2 2.0.0-5.2.

References

Show 43 moreShow less
MoveEnter Open