CVE-2006-6879
Unrestricted file upload vulnerability in admin/uploads.php in PHP-Update 2.7 and earlier allows...
Unrestricted file upload vulnerability in admin/uploads.php in PHP-Update 2.7 and earlier allows remote authenticated users to upload arbitrary PHP scripts to the gfx/ and files/ directories via the userfile parameter.
Exploit likelihood
What each source reports
NVD Score used
6.0
Unrestricted file upload vulnerability in admin/uploads.php in PHP-Update 2.7 and earlier allows remote authenticated users to upload arbitrary PHP scripts to the gfx/ and files/ directories via the userfile parameter.
- Record
CVE-2006-6879- CVSS 2.0
- 6.0 Medium
AV:N/AC:M/Au:S/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Unrestricted file upload vulnerability in admin/uploads.php in PHP-Update 2.7 and earlier allows remote authenticated users to upload arbitrary PHP scripts to the gfx/ and files/ directories via the userfile parameter.
- Record
CVE-2006-6879- Updated
- 2026-11-02
EUVDEUVD-2006-6862 No score
Unrestricted file upload vulnerability in admin/uploads.php in PHP-Update 2.7 and earlier allows remote authenticated users to upload arbitrary PHP scripts to the gfx/ and files/ directories via the userfile parameter.
- Record
EUVD-2006-6862- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jv75-9pg5-5jvv No score
Unrestricted file upload vulnerability in admin/uploads.php in PHP-Update 2.7 and earlier allows...
Unrestricted file upload vulnerability in admin/uploads.php in PHP-Update 2.7 and earlier allows remote authenticated users to upload arbitrary PHP scripts to the gfx/ and files/ directories via the userfile parameter.
- Record
GHSA-jv75-9pg5-5jvv- Updated
- 2026-11-02
Affected products
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | PHP-Update 2.7 - Multiple Vulnerabilities | 2006-12-26 |
| Exploit-DB | PHP-Update 2.7 - '/admin/uploads.php' Remote Code Execution | 2006-12-26 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2006-6879 is a medium vulnerability (CVSS 6.0) in Php-update, published December 31, 2006. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.89%, the 79th percentile. No source names a fixed version.