Every CVE Search/ Get API key

CVE-2007-1870

lighttpd before 1.4.14 allows attackers to cause a denial of service (crash) via a request to a...

7.8 HighFix available

lighttpd before 1.4.14 allows attackers to cause a denial of service (crash) via a request to a file whose mtime is 0, which results in a NULL pointer dereference.

Exploit likelihood

2.72%Unchanged since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.8

lighttpd before 1.4.14 allows attackers to cause a denial of service (crash) via a request to a file whose mtime is 0, which results in a NULL pointer dereference.

Record
CVE-2007-1870
CVSS 2.0
7.8 HighAV:N/AC:L/Au:N/C:N/I:N/A:C
Updated
2026-11-02
CVE List No score

lighttpd before 1.4.14 allows attackers to cause a denial of service (crash) via a request to a file whose mtime is 0, which results in a NULL pointer dereference.

Record
CVE-2007-1870
Updated
2026-11-02
EUVDEUVD-2007-1864 No score

lighttpd before 1.4.14 allows attackers to cause a denial of service (crash) via a request to a file whose mtime is 0, which results in a NULL pointer dereference.

Record
EUVD-2007-1864
Updated
2026-11-03
GitHub AdvisoriesGHSA-rw53-4php-w9w3 No score

lighttpd before 1.4.14 allows attackers to cause a denial of service (crash) via a request to a...

lighttpd before 1.4.14 allows attackers to cause a denial of service (crash) via a request to a file whose mtime is 0, which results in a NULL pointer dereference.

Record
GHSA-rw53-4php-w9w3
Updated
2026-11-02
OSV No score

lighttpd before 1.4.14 allows attackers to cause a denial of service (crash) via a request to a file whose mtime is 0, which results in a NULL pointer dereference.

Record
CVE-2007-1870
Updated
2026-11-02
OSVDEBIAN-CVE-2007-1870 No score

lighttpd before 1.4.14 allows attackers to cause a denial of service (crash) via a request to a file whose mtime is 0, which results in a NULL pointer dereference.

Record
DEBIAN-CVE-2007-1870
Updated
2026-11-02
OSVopenSUSE-SU-2024:10585-1 No score

lighttpd-1.4.59-2.1 on GA media

These are all security issues fixed in the lighttpd-1.4.59-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10585-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lighttpd
Debian:12
before 1.4.15-1
1.4.15-1
lighttpd
Debian:13
before 1.4.15-1
1.4.15-1
lighttpd
Debian:14
before 1.4.15-1
1.4.15-1
lighttpd
Debian:4.0
From an advisory covering 2 CVEs
before 1.4.13-4etch1, plus listed versions
1.4.13-4
1.4.13-4etch1
lighttpd
openSUSE:Tumbleweed
From an advisory covering 8 CVEs
before 1.4.59-2.1
1.4.59-2.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
aliases
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-1870 is a high vulnerability (CVSS 7.8) in Lighttpd, published April 18, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.72%, the 86th percentile. Fixed in lighttpd 1.4.15-1.

References

Show 19 moreShow less
MoveEnter Open