Every CVE Search/ Get API key

CVE-2007-2024

Unrestricted file upload vulnerability in the UpLoad feature (lib/plugin/UpLoad.php) in PhpWiki 1...

6.8 MediumFix available

Unrestricted file upload vulnerability in the UpLoad feature (lib/plugin/UpLoad.php) in PhpWiki 1.3.x allows remote attackers to upload arbitrary PHP files with a (1) php3, (2) php4, or (3) php5 extension.

Exploit likelihood

3.28%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Unrestricted file upload vulnerability in the UpLoad feature (lib/plugin/UpLoad.php) in PhpWiki 1.3.x allows remote attackers to upload arbitrary PHP files with a (1) php3, (2) php4, or (3) php5 extension.

Record
CVE-2007-2024
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Unrestricted file upload vulnerability in the UpLoad feature (lib/plugin/UpLoad.php) in PhpWiki 1.3.x allows remote attackers to upload arbitrary PHP files with a (1) php3, (2) php4, or (3) php5 extension.

Record
CVE-2007-2024
Updated
2026-11-02
EUVDEUVD-2007-2019 No score

Unrestricted file upload vulnerability in the UpLoad feature (lib/plugin/UpLoad.php) in PhpWiki 1.3.x allows remote attackers to upload arbitrary PHP files with a (1) php3, (2) php4, or (3) php5 extension.

Record
EUVD-2007-2019
Updated
2026-11-03
GitHub AdvisoriesGHSA-f2wc-3mgf-f3vx No score

Unrestricted file upload vulnerability in the UpLoad feature (lib/plugin/UpLoad.php) in PhpWiki 1...

Unrestricted file upload vulnerability in the UpLoad feature (lib/plugin/UpLoad.php) in PhpWiki 1.3.x allows remote attackers to upload arbitrary PHP files with a (1) php3, (2) php4, or (3) php5 extension.

Record
GHSA-f2wc-3mgf-f3vx
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpwiki
Debian:4.0
before 1.3.12p3-5etch1, plus listed versions
1.3.12p3-5
1.3.12p3-5etch1

History

History
RecordedChangedSources
aliasesEUVD
affected, aliases, facts, references, titleGitHub Advisories, OSV
first indexedCVE List, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-2024 is a medium vulnerability (CVSS 6.8) in Phpwiki, published April 13, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.28%, the 88th percentile. Fixed in phpwiki 1.3.12p3-5etch1.

References

Show 7 moreShow less
MoveEnter Open