CVE-2007-2348
mirror --script in lftp before 3.5.9 does not properly quote shell metacharacters, which might...
mirror --script in lftp before 3.5.9 does not properly quote shell metacharacters, which might allow remote user-assisted attackers to execute shell commands via a malicious script. NOTE: it is not clear whether this issue crosses security boundaries, since the script already supports commands such as "get" which could overwrite executable files.
Exploit likelihood
What each source reports
NVD Score used
6.8
mirror --script in lftp before 3.5.9 does not properly quote shell metacharacters, which might allow remote user-assisted attackers to execute shell commands via a malicious script. NOTE: it is not clear whether this issue crosses security boundaries, since the script already supports commands such as "get" which could overwrite executable files.
- Record
CVE-2007-2348- CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
mirror --script in lftp before 3.5.9 does not properly quote shell metacharacters, which might allow remote user-assisted attackers to execute shell commands via a malicious script. NOTE: it is not clear whether this issue crosses security boundaries, since the script already supports commands such as "get" which could overwrite executable files.
- Record
CVE-2007-2348- Updated
- 2026-11-02
EUVDEUVD-2007-2343 No score
mirror --script in lftp before 3.5.9 does not properly quote shell metacharacters, which might allow remote user-assisted attackers to execute shell commands via a malicious script. NOTE: it is not clear whether this issue crosses security boundaries, since the script already supports commands such as "get" which could overwrite executable files.
- Record
EUVD-2007-2343- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m4hr-2hrx-m38c No score
mirror --script in lftp before 3.5.9 does not properly quote shell metacharacters, which might...
mirror --script in lftp before 3.5.9 does not properly quote shell metacharacters, which might allow remote user-assisted attackers to execute shell commands via a malicious script. NOTE: it is not clear whether this issue crosses security boundaries, since the script already supports commands such as "get" which could overwrite executable files.
- Record
GHSA-m4hr-2hrx-m38c- Updated
- 2026-11-02
OSV No score
mirror --script in lftp before 3.5.9 does not properly quote shell metacharacters, which might allow remote user-assisted attackers to execute shell commands via a malicious script. NOTE: it is not clear whether this issue crosses security boundaries, since the script already supports commands such as "get" which could overwrite executable files.
- Record
CVE-2007-2348- Updated
- 2026-11-02
OSVDEBIAN-CVE-2007-2348 No score
mirror --script in lftp before 3.5.9 does not properly quote shell metacharacters, which might allow remote user-assisted attackers to execute shell commands via a malicious script. NOTE: it is not clear whether this issue crosses security boundaries, since the script already supports commands such as "get" which could overwrite executable files.
- Record
DEBIAN-CVE-2007-2348- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lftpDebian:12 |
before 3.5.9-1 | 3.5.9-1 |
lftpDebian:13 |
before 3.5.9-1 | 3.5.9-1 |
lftpDebian:14 |
before 3.5.9-1 | 3.5.9-1 |
lftpRed Hat:enterprise_linux:5::client |
before 0:3.7.11-4.el5 | 0:3.7.11-4.el5 |
lftp-debuginfoRed Hat:enterprise_linux:5::client |
before 0:3.7.11-4.el5 | 0:3.7.11-4.el5 |
lftpRed Hat:enterprise_linux:5::server |
before 0:3.7.11-4.el5 | 0:3.7.11-4.el5 |
lftp-debuginfoRed Hat:enterprise_linux:5::server |
before 0:3.7.11-4.el5 | 0:3.7.11-4.el5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| affected, aliases, facts, references, title | GitHub Advisories, OSV | |
| first indexed | CVE List, NVD |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2007-2348 is a medium vulnerability (CVSS 6.8) in Alexander V. Lukyanov Lftp, published April 27, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.17%, the 88th percentile. Fixed in lftp 3.5.9-1.
References
secunia.com/advisories/36559
vupen.com/english/advisories/2007/1590
issues.rpath.com/browse/RPL-1229
bugs.gentoo.org/show_bug.cgi?id=173524
secunia.com/advisories/25107
rhn.redhat.com/errata/RHSA-2009-1278.html
Show 18 moreShow less
securityfocus.com/bid/23736
lftp.yar.ru/news.html
secunia.com/advisories/25132
oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10806
nvd.nist.gov/vuln/detail/CVE-2007-2348
github.com/advisories/GHSA-m4hr-2hrx-m38c
security-tracker.debian.org/tracker/CVE-2007-2348
access.redhat.com/errata/RHSA-2009:1278
access.redhat.com/security/updates/classification
bugzilla.redhat.com/show_bug.cgi?id=236238
bugzilla.redhat.com/show_bug.cgi?id=239334
bugzilla.redhat.com/show_bug.cgi?id=308721
bugzilla.redhat.com/show_bug.cgi?id=422881
bugzilla.redhat.com/show_bug.cgi?id=434294
bugzilla.redhat.com/show_bug.cgi?id=461922
security.access.redhat.com/data/csaf/v2/advisories/2009/rhsa-2009_1278.json
access.redhat.com/security/cve/CVE-2007-2348
cve.org/CVERecord?id=CVE-2007-2348