Every CVE Search/ Get API key

CVE-2007-2500

server/parser/sprite_definition.cpp in GNU Gnash (aka GNU Flash Player) 0.7.2 allows remote...

10.0 HighFix available

server/parser/sprite_definition.cpp in GNU Gnash (aka GNU Flash Player) 0.7.2 allows remote attackers to execute arbitrary code via a large number of SHOWFRAME elements within a DEFINESPRITE element, which triggers memory corruption and enables the attacker to call free with an arbitrary address, probably resultant from a buffer overflow.

Exploit likelihood

5.39%Down 2.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

server/parser/sprite_definition.cpp in GNU Gnash (aka GNU Flash Player) 0.7.2 allows remote attackers to execute arbitrary code via a large number of SHOWFRAME elements within a DEFINESPRITE element, which triggers memory corruption and enables the attacker to call free with an arbitrary address, probably resultant from a buffer overflow.

Record
CVE-2007-2500
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

server/parser/sprite_definition.cpp in GNU Gnash (aka GNU Flash Player) 0.7.2 allows remote attackers to execute arbitrary code via a large number of SHOWFRAME elements within a DEFINESPRITE element, which triggers memory corruption and enables the attacker to call free with an arbitrary address, probably resultant from a buffer overflow.

Record
CVE-2007-2500
Updated
2026-11-02
EUVDEUVD-2007-2493 No score

server/parser/sprite_definition.cpp in GNU Gnash (aka GNU Flash Player) 0.7.2 allows remote attackers to execute arbitrary code via a large number of SHOWFRAME elements within a DEFINESPRITE element, which triggers memory corruption and enables the attacker to call free with an arbitrary address, probably resultant from a buffer overflow.

Record
EUVD-2007-2493
Updated
2026-11-03
GitHub AdvisoriesGHSA-c6p3-c4g7-pprg No score

server/parser/sprite_definition.cpp in GNU Gnash (aka GNU Flash Player) 0.7.2 allows remote...

server/parser/sprite_definition.cpp in GNU Gnash (aka GNU Flash Player) 0.7.2 allows remote attackers to execute arbitrary code via a large number of SHOWFRAME elements within a DEFINESPRITE element, which triggers memory corruption and enables the attacker to call free with an arbitrary address, probably resultant from a buffer overflow.

Record
GHSA-c6p3-c4g7-pprg
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gnash
Debian:5.0
before 0.7.2-1lenny1
0.7.2-1lenny1

History

History
RecordedChangedSources
aliasesEUVD
affected, aliases, facts, references, titleGitHub Advisories, OSV
first indexedCVE List, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-2500 is a high vulnerability (CVSS 10.0) in Gnu Flash Player, published May 4, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.39%, the 92nd percentile. Fixed in gnash 0.7.2-1lenny1.

References

Show 4 moreShow less
MoveEnter Open