Every CVE Search/ Get API key

CVE-2007-6531

Stack-based buffer overflow in the Panel (xfce4-panel) component in Xfce before 4.4.2 might allow...

5.0 MediumFix available

Stack-based buffer overflow in the Panel (xfce4-panel) component in Xfce before 4.4.2 might allow remote attackers to execute arbitrary code via Launcher tooltips. NOTE: a second buffer overflow (over-read) in the xfce_mkdirhier function was also reported, but it might not be exploitable for a crash or code execution, so it is not a vulnerability.

Exploit likelihood

2.93%Down 4.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Stack-based buffer overflow in the Panel (xfce4-panel) component in Xfce before 4.4.2 might allow remote attackers to execute arbitrary code via Launcher tooltips. NOTE: a second buffer overflow (over-read) in the xfce_mkdirhier function was also reported, but it might not be exploitable for a crash or code execution, so it is not a vulnerability.

Record
CVE-2007-6531
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Stack-based buffer overflow in the Panel (xfce4-panel) component in Xfce before 4.4.2 might allow remote attackers to execute arbitrary code via Launcher tooltips. NOTE: a second buffer overflow (over-read) in the xfce_mkdirhier function was also reported, but it might not be exploitable for a crash or code execution, so it is not a vulnerability.

Record
CVE-2007-6531
Updated
2026-11-02
EUVDEUVD-2007-6497 No score

Stack-based buffer overflow in the Panel (xfce4-panel) component in Xfce before 4.4.2 might allow remote attackers to execute arbitrary code via Launcher tooltips. NOTE: a second buffer overflow (over-read) in the xfce_mkdirhier function was also reported, but it might not be exploitable for a crash or code execution, so it is not a vulnerability.

Record
EUVD-2007-6497
Updated
2026-11-03
GitHub AdvisoriesGHSA-w2pc-w76j-jcg2 No score

Stack-based buffer overflow in the Panel (xfce4-panel) component in Xfce before 4.4.2 might allow...

Stack-based buffer overflow in the Panel (xfce4-panel) component in Xfce before 4.4.2 might allow remote attackers to execute arbitrary code via Launcher tooltips. NOTE: a second buffer overflow (over-read) in the xfce_mkdirhier function was also reported, but it might not be exploitable for a crash or code execution, so it is not a vulnerability.

Record
GHSA-w2pc-w76j-jcg2
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Stack-based buffer overflow in the Panel (xfce4-panel) component in Xfce before 4.4.2 might allow remote attackers to execute arbitrary code via Launcher tooltips. NOTE: a second buffer overflow (over-read) in the xfce_mkdirhier function was also reported, but it might not be exploitable for a crash or code execution, so it is not a vulnerability.

Record
CVE-2007-6531
Updated
2026-11-02
OSVDEBIAN-CVE-2007-6531 No score

Stack-based buffer overflow in the Panel (xfce4-panel) component in Xfce before 4.4.2 might allow remote attackers to execute arbitrary code via Launcher tooltips. NOTE: a second buffer overflow (over-read) in the xfce_mkdirhier function was also reported, but it might not be exploitable for a crash or code execution, so it is not a vulnerability.

Record
DEBIAN-CVE-2007-6531
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xfce4-panel
Debian:12
before 4.4.2
4.4.2
xfce4-panel
Debian:13
before 4.4.2
4.4.2
xfce4-panel
Debian:14
before 4.4.2
4.4.2

History

History
RecordedChangedSources
aliasesEUVD
affected, aliases, facts, references, titleGitHub Advisories, OSV
first indexedCVE List, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-6531 is a medium vulnerability (CVSS 5.0) in Xfce, published January 9, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.93%, the 87th percentile. Fixed in xfce4-panel 4.4.2.

References

MoveEnter Open